aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-07-17 20:17:12 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-07-17 20:17:59 +0000
commit64e758e582bc124c5210768d2aff100cf0d5e306 (patch)
treed10251090f2f5397312cd2e188e8d63da29a7b0e /testing
parentafa66c07801b5c2dc97a9c10d7fb38e40bda2c5a (diff)
downloadaports-64e758e582bc124c5210768d2aff100cf0d5e306.tar.bz2
aports-64e758e582bc124c5210768d2aff100cf0d5e306.tar.xz
testing/slurm: remove -O0 compile option
I was not able to reproduce the commented issue. if -Os is broken, then we need to troubleshoot it and fix it.
Diffstat (limited to 'testing')
-rw-r--r--testing/slurm/APKBUILD5
1 files changed, 1 insertions, 4 deletions
diff --git a/testing/slurm/APKBUILD b/testing/slurm/APKBUILD
index 4b61db8a59..b08e54aced 100644
--- a/testing/slurm/APKBUILD
+++ b/testing/slurm/APKBUILD
@@ -21,12 +21,9 @@ build() {
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
- # Optimizations beyond -O0 result in the binary failing to execute past the help
- # screen. Upon execution, the failing binary will exit producing the message:
- # "Illegal instruction"
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_C_FLAGS="${CFLAGS/-Os/-O0} -Wno-aggressive-loop-optimizations" \
+ -DCMAKE_C_FLAGS="${CFLAGS} -Wno-aggressive-loop-optimizations" \
${CMAKE_CROSSOPTS}
make
}