aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-03 01:17:50 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-03-03 01:18:30 +0100
commit65432e561ffb2ca1c404187bc8156dc8ce1e6687 (patch)
tree00add94c96dafc2b15707871b6d1295f52bc680b /testing
parentea14afc969bd5ea16df3f9584b41a7dbc1e3d89c (diff)
downloadaports-65432e561ffb2ca1c404187bc8156dc8ce1e6687.tar.bz2
aports-65432e561ffb2ca1c404187bc8156dc8ce1e6687.tar.xz
testing/gobolight: new aport
https://github.com/gobolinux/GoboLight/ Ultra-minimal backlight tool
Diffstat (limited to 'testing')
-rw-r--r--testing/gobolight/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/gobolight/APKBUILD b/testing/gobolight/APKBUILD
new file mode 100644
index 0000000000..ee4ef00d8e
--- /dev/null
+++ b/testing/gobolight/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=gobolight
+_pkgname=GoboLight
+pkgver=0.1
+pkgrel=0
+pkgdesc="Ultra-minimal backlight tool"
+url="https://github.com/gobolinux/GoboLight"
+arch="all"
+license="GPL-3.0-or-later"
+makedepends="autoconf automake"
+options="suid !check" # no tests provided
+source="$pkgname-$pkgver.tar.gz::https://github.com/gobolinux/$_pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+
+ cd "$builddir"
+ ./autogen.sh
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc
+ make
+}
+
+package() {
+ cd "$builddir"
+ make install -j1 DESTDIR="$pkgdir"
+}
+
+sha512sums="1c990cf5dae617ebd230da2bcaa79fea652106051cd4584a69b33cb66a3bfa94f71623e2e30104c9a95958cc2417a20c8cf179709ba826216b57a1c7e2a77e7c gobolight-0.1.tar.gz"