aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-03-16 11:57:08 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-03-16 11:57:39 +0100
commit65af36d3bff75efad9ae4eeeff11294e822d0453 (patch)
tree44c57a3b788e6cee89b067e6a78f4588f1619877 /testing
parent155ee3e70eaad24c62490106e4f51b5e188b0e28 (diff)
downloadaports-65af36d3bff75efad9ae4eeeff11294e822d0453.tar.bz2
aports-65af36d3bff75efad9ae4eeeff11294e822d0453.tar.xz
testing/diff-pdf: new aport
https://vslavik.github.io/diff-pdf/ A simple tool for visually comparing two PDF files
Diffstat (limited to 'testing')
-rw-r--r--testing/diff-pdf/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/diff-pdf/APKBUILD b/testing/diff-pdf/APKBUILD
new file mode 100644
index 0000000000..ea1df4540e
--- /dev/null
+++ b/testing/diff-pdf/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+# TODO: Try to build it without GUI.
+pkgname=diff-pdf
+pkgver=0.2_git20161028
+_gitrev=75d63d243155f60cf1794d6a2535c45bcd9c95d6
+pkgrel=0
+pkgdesc="A simple tool for visually comparing two PDF files"
+url="https://vslavik.github.io/diff-pdf/"
+arch="all"
+license="GPL2"
+makedepends="autoconf automake cairo-dev poppler-dev wxgtk-dev"
+source="$pkgname-$_gitrev.tar.gz::https://github.com/vslavik/$pkgname/archive/$_gitrev.tar.gz"
+builddir="$srcdir/$pkgname-$_gitrev"
+
+prepare() {
+ cd "$builddir"
+ ./bootstrap
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --disable-silent-rules \
+ && make
+}
+
+check() {
+ cd "$builddir"
+ ./diff-pdf --help >/dev/null
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="481fb05197a7a3d22e1df695d89666cdf6e3459cca0bbe571206ce9259269515969303843f9b048769d06381303efdd723fa27902d4bd785a67c937b96039519 diff-pdf-75d63d243155f60cf1794d6a2535c45bcd9c95d6.tar.gz"