aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorIsaac Dunham <ibid.ag@gmail.com>2014-11-26 22:33:16 -0800
committerNatanael Copa <ncopa@alpinelinux.org>2014-11-27 10:47:58 +0000
commit6701b19009a2e30c128aa9e748f3b3c6c049a5f4 (patch)
tree706e8665ac6db726a6fc084f7818672846656640 /testing
parent79ec102ae14da1c21af3b85109c39d12a6ad6337 (diff)
downloadaports-6701b19009a2e30c128aa9e748f3b3c6c049a5f4.tar.bz2
aports-6701b19009a2e30c128aa9e748f3b3c6c049a5f4.tar.xz
testing/gifsicle: new aport
gifsicle provides three tools: gifsicle, which can animate/split/optimize/unoptimize GIF images; gifdiff, which determines whether two GIFs appear identical; and gifview, a simple viewer for animated GIFs. gifview is the only one that uses X11, so it may be worthwhile to split it out.
Diffstat (limited to 'testing')
-rw-r--r--testing/gifsicle/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/testing/gifsicle/APKBUILD b/testing/gifsicle/APKBUILD
new file mode 100644
index 0000000000..8f3fe41839
--- /dev/null
+++ b/testing/gifsicle/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Isaac Dunham <ibid.ag@gmail.com>
+# Maintainer: Isaac Dunham <ibid.ag@gmail.com>
+pkgname=gifsicle
+pkgver=1.86
+pkgrel=0
+pkgdesc="Command-line tool for making, editing, and getting information about GIF animations"
+url="http://www.lcdf.org/gifsicle/"
+arch="all"
+license="GPL2"
+depends=""
+makedepends="libx11-dev libice-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://www.lcdf.org/gifsicle/gifsicle-$pkgver.tar.gz"
+
+_builddir="$srcdir"/gifsicle-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="5eadf90cf7a6f22447b0f146e146d092 gifsicle-1.86.tar.gz"
+sha256sums="b0046d5e619240de00a6401e0056843cd57006f674e2babe0e9013e0dcb47394 gifsicle-1.86.tar.gz"
+sha512sums="d55609e5d71f63ec13c1eed6a9071d756f07c765d2496d468cc7291e3b9e29304be1c3a5b0e822d9dc2df29ac489bafca2650d226d5b3c51dad74dd22c725a13 gifsicle-1.86.tar.gz"