aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-07-11 20:21:21 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-07-12 12:59:30 +0200
commit671289c0477cf2484554a9d1d5f1898db57fbe73 (patch)
tree4efb5273f59515f9824d77fb1cb666e6e3246260 /testing
parent07cd9f6674dbcf7dc9af4ded61196d47e68b8db2 (diff)
downloadaports-671289c0477cf2484554a9d1d5f1898db57fbe73.tar.bz2
aports-671289c0477cf2484554a9d1d5f1898db57fbe73.tar.xz
testing/sbcl: upgrade to 1.4.9
The first sed is ineffective now (i.e. does not change the file) and it seems that correct flags are used. Patch no-pie is not needed anymore, no-pie is already set in src/runtime/GNUMakefile.
Diffstat (limited to 'testing')
-rw-r--r--testing/sbcl/APKBUILD15
-rw-r--r--testing/sbcl/musl-fixes.patch11
-rw-r--r--testing/sbcl/no-pie.patch22
3 files changed, 4 insertions, 44 deletions
diff --git a/testing/sbcl/APKBUILD b/testing/sbcl/APKBUILD
index e49a83c31e..5d493ec981 100644
--- a/testing/sbcl/APKBUILD
+++ b/testing/sbcl/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer:
pkgname=sbcl
-pkgver=1.3.16
+pkgver=1.4.9
pkgrel=0
pkgdesc="Steel Bank Common Lisp"
url="http://www.sbcl.org/"
@@ -16,7 +16,6 @@ source="$pkgname-$pkgver.tar.bz2::http://prdownloads.sourceforge.net/$pkgname/$p
pax-genesis-stage-two.patch
ignore-test-failure.patch
musl-fixes.patch
- no-pie.patch
config"
builddir="$srcdir"/$pkgname-$pkgver
@@ -24,12 +23,7 @@ prepare() {
default_prepare
cp "$srcdir"/config "$builddir"/customize-target-features.lisp
- sed -e "s@CFLAGS =.*\$@CFLAGS = ${CFLAGS} -D_GNU_SOURCE@" \
- -e "s@LINKFLAGS =.*\$@LINKFLAGS = ${LDFLAGS}@" \
- -i src/runtime/GNUmakefile
-
- sed -e 's@SBCL_PREFIX=\"/usr/local\"@SBCL_PREFIX=\"/usr\"@' \
- -i make-config.sh
+ sed -i 's@SBCL_PREFIX=\"/usr/local\"@SBCL_PREFIX=\"/usr\"@' make-config.sh
}
build() {
@@ -51,9 +45,8 @@ package() {
"$pkgdir"/usr/share/info 2>/dev/null || true
}
-sha512sums="6bb0a7c926ba8031c319697b49b85eb58ea262d47237b2e7735738ad6103a759016a269e617931095174066f830e2edc362bf89384a97c3d19807552caf826b4 sbcl-1.3.16.tar.bz2
+sha512sums="e0248f460f9737d47653dd520732062d2637813b550df356ecc90aa6d21fbdd74f03182d1e890c09c1da742f7d57b4fbd04a4e6dc36999aca51bb6c2952ac236 sbcl-1.4.9.tar.bz2
cda5c7268b314145a1bdb8293c7970e077aebf3cce5dace12542bf18beb7b124bf97f4754906f2f681428869ca3060300b88cab80055a3d5881dfcdcfbe51d6d pax-genesis-stage-two.patch
fcaf0754084d705b263cbca20988e2cacc96470d4f0f2e15b812678ba8d15a43de2b3ebd87648f6540833615fdbde0011f72ce7800b02dcbd8055229eb439ec3 ignore-test-failure.patch
-8f4b83ff626536a4b10b4361115b0ac45ee6bccf1b090f9ca56ef52bd0ddbc7caf096b96de122ee88152e1f8dc26aca74bdd4e15895f0893cd98aed4b9aa4d1a musl-fixes.patch
-124920cea17f586924bca4edeca3078574f16a4c95601a6d4fdc538cb116e85f95ffd342c23fbf4383eeff1e8e116b6bb896744740940e4a24085356ed43a1c0 no-pie.patch
+19bb9dac5997366c9778e349b707970832c5020ac55f0099dd652a8cc8c43336d34a33db2e4f7f190ab8212b064718f6999b832c249a4de7d24eae2186d6acea musl-fixes.patch
03516a49ae8753e254a0a3fa48429d796ffacbc08360d8a41563cf8e3c3fe7fd6989021be6733549460bd78575cd5267fab9315dec53b16f5c349a990f4597dc config"
diff --git a/testing/sbcl/musl-fixes.patch b/testing/sbcl/musl-fixes.patch
index 530467e102..7581d7826d 100644
--- a/testing/sbcl/musl-fixes.patch
+++ b/testing/sbcl/musl-fixes.patch
@@ -21,14 +21,3 @@ diff -upr sbcl-1.3.1.orig/src/runtime/linux-os.h sbcl-1.3.1/src/runtime/linux-os
typedef size_t os_vm_size_t;
typedef off_t os_vm_offset_t;
typedef int os_vm_prot_t;
-diff -upr sbcl-1.3.8.orig/src/runtime/wrap.c sbcl-1.3.8/src/runtime/wrap.c
---- sbcl-1.3.8.orig/src/runtime/wrap.c 2016-08-10 21:35:04.691583991 +0200
-+++ sbcl-1.3.8/src/runtime/wrap.c 2016-08-10 21:35:25.371508919 +0200
-@@ -35,6 +35,7 @@
- #include <errno.h>
- #include <limits.h>
- #include <fcntl.h>
-+#include <time.h>
-
- #ifndef LISP_FEATURE_WIN32
- #include <pwd.h>
diff --git a/testing/sbcl/no-pie.patch b/testing/sbcl/no-pie.patch
deleted file mode 100644
index 59ecf8c43d..0000000000
--- a/testing/sbcl/no-pie.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- sbcl-1.1.17-orig/src/runtime/Config.x86-linux 2014-03-31 03:14:22.000000000 +1100
-+++ sbcl-1.1.17/src/runtime/Config.x86-linux 2014-04-28 15:34:59.822482441 +1000
-@@ -27,7 +27,7 @@
- # (You *are* encouraged to design and implement a coherent stable
- # interface, though.:-| As far as I (WHN 2002-05-19) know, no one is
- # working on one and it would be a nice thing to have.)
--LINKFLAGS += -Wl,--export-dynamic -m32
-+LINKFLAGS += -Wl,--export-dynamic -m32 -no-pie
- OS_LIBS = -ldl
-
- ifdef LISP_FEATURE_LARGEFILE
---- sbcl-1.1.17-orig/src/runtime/Config.x86-64-linux 2014-03-31 03:14:22.000000000 +1100
-+++ sbcl-1.1.17/src/runtime/Config.x86-64-linux 2014-04-28 15:35:22.364623003 +1000
-@@ -27,7 +27,7 @@
- # (You *are* encouraged to design and implement a coherent stable
- # interface, though.:-| As far as I (WHN 2002-05-19) know, no one is
- # working on one and it would be a nice thing to have.)
--LINKFLAGS += -Wl,--export-dynamic
-+LINKFLAGS += -Wl,--export-dynamic -no-pie
- OS_LIBS = -ldl
-
- ifdef LISP_FEATURE_LARGEFILE