aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-04-01 19:36:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-04-02 10:31:58 +0000
commit6e3ec714c226087606d236468f2512790db0dac2 (patch)
tree0fcf36b2da983005fe2e27f615dd32c3e0ffcf7b /testing
parent57c38e109e4fa2f968c1decb029684034b8bd357 (diff)
downloadaports-6e3ec714c226087606d236468f2512790db0dac2.tar.bz2
aports-6e3ec714c226087606d236468f2512790db0dac2.tar.xz
testing/pcl: rebuild against boost-1.69
Diffstat (limited to 'testing')
-rw-r--r--testing/pcl/APKBUILD8
-rw-r--r--testing/pcl/gcc8.patch36
2 files changed, 41 insertions, 3 deletions
diff --git a/testing/pcl/APKBUILD b/testing/pcl/APKBUILD
index 1199e572ef..ace448b75a 100644
--- a/testing/pcl/APKBUILD
+++ b/testing/pcl/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bradley J Chambers <brad.chambers@gmail.com>
pkgname=pcl
pkgver=1.8.1
-pkgrel=2
+pkgrel=3
pkgdesc="Point Cloud Library (PCL)"
url="https://github.com/PointCloudLibrary/pcl"
arch="all !x86 !s390x" # tests fails on x86 and s390x
@@ -12,7 +12,8 @@ makedepends="cmake eigen-dev boost-dev flann-dev"
subpackages="$pkgname-dev"
_gtestver=1.8.0
source="$pkgname-$pkgver.tar.gz::https://github.com/PointCloudLibrary/$pkgname/archive/$pkgname-$pkgver.tar.gz
- release-$_gtestver.tar.gz::https://github.com/google/googletest/archive/release-$_gtestver.tar.gz"
+ release-$_gtestver.tar.gz::https://github.com/google/googletest/archive/release-$_gtestver.tar.gz
+ gcc8.patch"
builddir="$srcdir/$pkgname-$pkgname-$pkgver"
build() {
@@ -72,4 +73,5 @@ check() {
}
sha512sums="9e7c87fb750a176712f08d215a906012c9e8174b687bbc8c08fa65de083b4468951bd8017b10409015d5eff0fc343885d2aae5c340346118b1a251af7bdd5cd7 pcl-1.8.1.tar.gz
-1dbece324473e53a83a60601b02c92c089f5d314761351974e097b2cf4d24af4296f9eb8653b6b03b1e363d9c5f793897acae1f0c7ac40149216035c4d395d9d release-1.8.0.tar.gz"
+1dbece324473e53a83a60601b02c92c089f5d314761351974e097b2cf4d24af4296f9eb8653b6b03b1e363d9c5f793897acae1f0c7ac40149216035c4d395d9d release-1.8.0.tar.gz
+16b3ca34fe31a3a7c9b1eefe818e963eda483b8d18a40e766306aaa653dd5d6072cd5dacb16c49e8905309ba179d0defb90c42aad1a3fb6c2d9fbde9b12e9ebc gcc8.patch"
diff --git a/testing/pcl/gcc8.patch b/testing/pcl/gcc8.patch
new file mode 100644
index 0000000000..aec883a804
--- /dev/null
+++ b/testing/pcl/gcc8.patch
@@ -0,0 +1,36 @@
+From a0b3ce9ca5c69a945695c1c83dab7937a3d99b83 Mon Sep 17 00:00:00 2001
+From: Jochen Sprickerhof <git@jochen.sprickerhof.de>
+Date: Sat, 5 May 2018 23:58:13 +0200
+Subject: [PATCH] Dereference shared_ptr, fix for GCC8
+
+---
+ segmentation/include/pcl/segmentation/ground_plane_comparator.h | 2 +-
+ .../include/pcl/segmentation/plane_coefficient_comparator.h | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/segmentation/include/pcl/segmentation/ground_plane_comparator.h b/segmentation/include/pcl/segmentation/ground_plane_comparator.h
+index e39354d7fd..f96f38bfb5 100644
+--- a/segmentation/include/pcl/segmentation/ground_plane_comparator.h
++++ b/segmentation/include/pcl/segmentation/ground_plane_comparator.h
+@@ -147,7 +147,7 @@ namespace pcl
+ const std::vector<float>&
+ getPlaneCoeffD () const
+ {
+- return (plane_coeff_d_);
++ return (*plane_coeff_d_);
+ }
+
+ /** \brief Set the tolerance in radians for difference in normal direction between neighboring points, to be considered part of the same plane.
+diff --git a/segmentation/include/pcl/segmentation/plane_coefficient_comparator.h b/segmentation/include/pcl/segmentation/plane_coefficient_comparator.h
+index 9c94813727..a21725a40c 100644
+--- a/segmentation/include/pcl/segmentation/plane_coefficient_comparator.h
++++ b/segmentation/include/pcl/segmentation/plane_coefficient_comparator.h
+@@ -141,7 +141,7 @@ namespace pcl
+ const std::vector<float>&
+ getPlaneCoeffD () const
+ {
+- return (plane_coeff_d_);
++ return (*plane_coeff_d_);
+ }
+
+ /** \brief Set the tolerance in radians for difference in normal direction between neighboring points, to be considered part of the same plane.