aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-25 16:50:03 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-25 17:07:21 -0300
commit731745727405cb377154e50888d0bcd63ba0eabe (patch)
treea63e6bafab121ddf23b264e4df09fb261773d9d7 /testing
parentac102840f47178917129808711dd935ea7c27d86 (diff)
downloadaports-731745727405cb377154e50888d0bcd63ba0eabe.tar.bz2
aports-731745727405cb377154e50888d0bcd63ba0eabe.tar.xz
testing/range-v3: upgrade to 0.9.0
Diffstat (limited to 'testing')
-rw-r--r--testing/range-v3/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/testing/range-v3/APKBUILD b/testing/range-v3/APKBUILD
index a1e4999afa..943d11e790 100644
--- a/testing/range-v3/APKBUILD
+++ b/testing/range-v3/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Leo <thinkabit.ukim@gmail.com>
pkgname=range-v3
-pkgver=0.5.0
+pkgver=0.9.0
pkgrel=0
pkgdesc="Experimental range library for C++11/14/17"
url="https://github.com/ericniebler/range-v3"
@@ -9,7 +9,7 @@ arch="noarch"
license="BSL-1.0"
makedepends="cmake"
subpackages="$pkgname-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/ericniebler/range-v3/archive/${pkgver}.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ericniebler/range-v3/archive/$pkgver.tar.gz"
build() {
sed -i -e '/Werror/d' -e '/Wextra/d' -e '/Wall/d' cmake/ranges_flags.cmake
@@ -28,7 +28,7 @@ build() {
-DRANGE_V3_TESTS=ON \
-DRANGE_BUILD_CALENDAR_EXAMPLE=OFF \
-DRANGES_NATIVE=ON \
- ${CMAKE_CROSSOPTS}
+ $CMAKE_CROSSOPTS
make
}
@@ -40,4 +40,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="076be03b0f4113acb5fb4db83ed5e755bed60ff8df9a7b982b144949cce40f0bb0579ecca38c1f33643b63037b8d311afa6d613b50811e1191b63e2c42a0d4bf range-v3-0.5.0.tar.gz"
+sha512sums="90964e37fd32526f10ab76879344d611c7ef83085610db2dc2d555b8056de9248b0c9195ea5912aaf77206fbd11b02055cf444c422bdfb050804f7ce601e5d8e range-v3-0.9.0.tar.gz"