aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-03-29 18:21:34 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-03-29 18:21:34 +0000
commit75588174d69a68283103f63671ce3b478592d96b (patch)
tree3344ffa5f8f013d9878cd97435434622bf9ffd9e /testing
parentd53bf71500668b33814570f313def0dc43e3766c (diff)
downloadaports-75588174d69a68283103f63671ce3b478592d96b.tar.bz2
aports-75588174d69a68283103f63671ce3b478592d96b.tar.xz
testing/libxspf: move to community
Diffstat (limited to 'testing')
-rw-r--r--testing/libxspf/APKBUILD38
-rw-r--r--testing/libxspf/add-missing-include.patch10
2 files changed, 0 insertions, 48 deletions
diff --git a/testing/libxspf/APKBUILD b/testing/libxspf/APKBUILD
deleted file mode 100644
index 3756b2294c..0000000000
--- a/testing/libxspf/APKBUILD
+++ /dev/null
@@ -1,38 +0,0 @@
-# Contributor: Roberto Oliveira <robertoguimaraes8@gmail.com>
-# Maintainer: Roberto Oliveira <robertoguimaraes8@gmail.com>
-pkgname=libxspf
-pkgver=1.2.0
-pkgrel=0
-pkgdesc="Brings XSPF playlist reading and writing support to C++ application"
-url="http://libspiff.sourceforge.net"
-arch="all"
-license="BSD"
-makedepends="expat-dev uriparser-dev cpptest-dev"
-subpackages="$pkgname-dev"
-source="http://downloads.xiph.org/releases/xspf/libxspf-1.2.0.tar.gz
- add-missing-include.patch"
-builddir="$srcdir/$pkgname-$pkgver"
-
-prepare() {
- default_prepare
- update_config_guess
-}
-
-build() {
- cd "$builddir"
- ./configure --prefix=/usr
- make
-}
-
-check() {
- cd "$builddir"
- make check
-}
-
-package() {
- cd "$builddir"
- make install DESTDIR="$pkgdir"
-}
-
-sha512sums="ff1816e782e8967c5d672acff268be33f21c2add86a057da6cee085ca87e9a985dc1ea07e94f046e95a18afaf55b014d089883cb9db0532f5ec0697ca4e806fb libxspf-1.2.0.tar.gz
-f511bf02791e348492f45901454ec8db6ac2c3f5d1707aff8aa3471853870eed89767564749412e13c0542585057da48c453412bd533418ecc1e2b2a103cc8d6 add-missing-include.patch"
diff --git a/testing/libxspf/add-missing-include.patch b/testing/libxspf/add-missing-include.patch
deleted file mode 100644
index 7cebb346a7..0000000000
--- a/testing/libxspf/add-missing-include.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/examples/read/read.cpp
-+++ b/examples/read/read.cpp
-@@ -43,6 +43,7 @@
- #include <cstdio>
- #include <cstdlib> // MAX_PATH
- #include <climits> // PATH_MAX
-+#include <unistd.h> // getcwd
-
-
- #if defined(__WIN32__) || defined(WIN32)