aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorValery Kartel <valery.kartel@gmail.com>2017-02-27 09:37:34 +0200
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-02-27 11:21:52 +0000
commit7bd8e1e3aa6853d20fca591028aad9134f97e7f2 (patch)
tree3b78f2df1a98c47d4c7d897cafabd4737c890f75 /testing
parent35e1be2d4cb88dcb6e9b96617f5b2b8d9ddf26a1 (diff)
downloadaports-7bd8e1e3aa6853d20fca591028aad9134f97e7f2.tar.bz2
aports-7bd8e1e3aa6853d20fca591028aad9134f97e7f2.tar.xz
testing/php7.1: switch back to bundled libgd
Diffstat (limited to 'testing')
-rw-r--r--testing/php7.1/APKBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/testing/php7.1/APKBUILD b/testing/php7.1/APKBUILD
index 3234471035..717daa1c96 100644
--- a/testing/php7.1/APKBUILD
+++ b/testing/php7.1/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Valery Kartel <valery.kartel@gmail.com>
pkgname=php7.1
pkgver=7.1.2
-pkgrel=2
+pkgrel=3
_apiver=20160303
_suffix=${pkgname#php}
_pkgreal=${pkgname%$_suffix}
@@ -18,7 +18,7 @@ provides="$replaces $pkgname-cli"
makedepends="autoconf bison re2c apache2-dev libxml2-dev libxslt-dev libzip-dev bzip2-dev zlib-dev
aspell-dev enchant-dev expat-dev pcre-dev curl-dev gmp-dev icu-dev imap-dev gd-dev
libical-dev libressl-dev openldap-dev net-snmp-dev db-dev krb5-dev gdbm-dev sqlite-dev
- freetds-dev mariadb-dev postgresql-dev unixodbc-dev freetype-dev tidyhtml-dev libxpm-dev
+ freetds-dev mariadb-dev postgresql-dev unixodbc-dev freetype-dev tidyhtml-dev libwebp-dev
libpng-dev libjpeg-turbo-dev libmcrypt-dev recode-dev libedit-dev gettext-dev file-dev
"
source="http://php.net/distributions/$_pkgreal-$pkgver.tar.bz2
@@ -98,7 +98,8 @@ _build() {
--with-enchant=shared \
--enable-exif=shared \
--enable-ftp=shared \
- --with-gd=shared,/usr --enable-gd-native-ttf --disable-gd-jis-conv \
+ --with-gd=shared --with-jpeg-dir --with-png-dir --with-webp-dir --with-xpm-dir=no \
+ --enable-gd-native-ttf --disable-gd-jis-conv \
--with-gettext=shared \
--with-gmp=shared \
--with-iconv=shared \
@@ -173,6 +174,10 @@ build() {
make
}
+check() {
+ :
+}
+
package() {
pkgdesc="$pkgdesc (command line interface)"