aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-06-12 16:50:55 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-06-12 17:43:06 +0200
commit7feadd908280effbe37152d7f5ecd7a0b59d030b (patch)
tree2c752ac2bf09e75a8d264290d7f79aca13971d9b /testing
parentfb922ad0b0559fad3d45bbb801e27f1e66fbdd29 (diff)
downloadaports-7feadd908280effbe37152d7f5ecd7a0b59d030b.tar.bz2
aports-7feadd908280effbe37152d7f5ecd7a0b59d030b.tar.xz
testing/perl-sys-cpu: new abuild
http://search.cpan.org/dist/Sys-CPU/ Perl extension for getting CPU information
Diffstat (limited to 'testing')
-rw-r--r--testing/perl-sys-cpu/0001-musl-compat.patch10
-rw-r--r--testing/perl-sys-cpu/APKBUILD46
2 files changed, 56 insertions, 0 deletions
diff --git a/testing/perl-sys-cpu/0001-musl-compat.patch b/testing/perl-sys-cpu/0001-musl-compat.patch
new file mode 100644
index 0000000000..0559551a97
--- /dev/null
+++ b/testing/perl-sys-cpu/0001-musl-compat.patch
@@ -0,0 +1,10 @@
+--- a/CPU.xs
++++ b/CPU.xs
+@@ -24,7 +24,6 @@
+ #include <winreg.h>
+ #else /* other (try unix) */
+ #include <unistd.h>
+- #include <sys/unistd.h>
+ #endif
+ #if defined(__sun) || defined(__sun__)
+ #include <sys/processor.h>
diff --git a/testing/perl-sys-cpu/APKBUILD b/testing/perl-sys-cpu/APKBUILD
new file mode 100644
index 0000000000..6d8a808450
--- /dev/null
+++ b/testing/perl-sys-cpu/APKBUILD
@@ -0,0 +1,46 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=perl-sys-cpu
+_pkgreal=Sys-CPU
+pkgver=0.61
+pkgrel=0
+pkgdesc="Perl extension for getting CPU information"
+url="http://search.cpan.org/dist/Sys-CPU/"
+arch="all"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends=""
+depends="$cpandepends"
+makedepends="perl-dev linux-headers $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/M/MZ/MZSANFORD/$_pkgreal-$pkgver.tar.gz
+ 0001-musl-compat.patch"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ default_prepare || return 1
+
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make && make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="f43a3a50ac2dca6c1485a859ebef09b2 Sys-CPU-0.61.tar.gz
+9d94c909cb3f08e410cd470cc006278d 0001-musl-compat.patch"
+sha256sums="250a86b79c231001c4ae71d2f66428092a4fbb2070971acafd471aa49739c9e4 Sys-CPU-0.61.tar.gz
+1fde5438497cd3ed925b30990e4fc493be7823eb13a169af0a6c3bef419ae648 0001-musl-compat.patch"
+sha512sums="391e113c87d9044cd43c47f9f78a782fab65566a32c028c01f7f3335a5065b6755586ea3143356510c8d28a7d1ad572cc6203ec189eaaa379967bdbd0a0bd7bc Sys-CPU-0.61.tar.gz
+7e3dd2efa3a9857b46d291510faf47c0120ece5705b9c58fc08a36d6ff54618acc8866554002572fa35768a44db319b59b73303e9a340734f28235d05f5174cb 0001-musl-compat.patch"