aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorIvan Tham <pickfire@riseup.net>2017-02-23 01:16:38 +0800
committerTimo Teräs <timo.teras@iki.fi>2017-02-23 07:16:18 +0000
commit800fc5058d9330ca53fc26b4f8717c7f3a1afcee (patch)
treeae9d6d693ce3d49f80a55f7571b6b20a9e3b6bf9 /testing
parent0d92055d0400718f71ec55d3c1539471ec666fa4 (diff)
downloadaports-800fc5058d9330ca53fc26b4f8717c7f3a1afcee.tar.bz2
aports-800fc5058d9330ca53fc26b4f8717c7f3a1afcee.tar.xz
testing/you-get: new aport
https://you-get.org/ Tiny command line utility to download media contents
Diffstat (limited to 'testing')
-rw-r--r--testing/you-get/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/you-get/APKBUILD b/testing/you-get/APKBUILD
new file mode 100644
index 0000000000..7982c81d3f
--- /dev/null
+++ b/testing/you-get/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Ivan Tham <pickfire@riseup.net>
+# Maintainer: Ivan Tham <pickfire@riseup.net>
+pkgname=you-get
+pkgver=0.4.652
+pkgrel=0
+pkgdesc="Tiny command line utility to download media contents"
+url="https://you-get.org/"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="python3-dev"
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/"$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+sha512sums="b3c736915492d9d921ec6866edb35acb12b5fb283663db8ad3d87325d06354697196ffdffef13291a709bd8bf5b5db6a61ee6288c083f0939d6ac8637b014ab4 you-get-0.4.652.tar.gz"