aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2017-06-05 21:27:49 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-06-05 21:29:05 +0000
commit801551b52109dbd16517451bcf5752360b91cff4 (patch)
treec2b11e3657330b5dd5b22b89140adc8c905c1fc9 /testing
parent9583687191c94fbbbaa9ffef729b3e8170dd725f (diff)
downloadaports-801551b52109dbd16517451bcf5752360b91cff4.tar.bz2
aports-801551b52109dbd16517451bcf5752360b91cff4.tar.xz
testing/mozjs-38: cleanups
Diffstat (limited to 'testing')
-rw-r--r--testing/mozjs-38/APKBUILD17
-rw-r--r--testing/mozjs-38/copy-headers.patch20
-rw-r--r--testing/mozjs-38/icu-add-bracket.patch16
-rw-r--r--testing/mozjs-38/pkg-config-version.patch22
4 files changed, 69 insertions, 6 deletions
diff --git a/testing/mozjs-38/APKBUILD b/testing/mozjs-38/APKBUILD
index e3643a50a1..b9c8224abf 100644
--- a/testing/mozjs-38/APKBUILD
+++ b/testing/mozjs-38/APKBUILD
@@ -1,25 +1,28 @@
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=mozjs-38
pkgver=38.8.0
-pkgrel=1
+pkgrel=2
pkgdesc="standalone mozilla javascript engine"
url="https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey/Releases/38"
arch="all"
license="LGPL"
depends=""
depends_dev="icu-dev nspr-dev libffi-dev readline-dev"
-makedepends="$depends_dev python2 perl"
+makedepends="$depends_dev python2 perl sed"
install=""
subpackages="$pkgname-dev"
source="https://ftp.mozilla.org/pub/firefox/releases/${pkgver}esr/source/firefox-${pkgver}esr.source.tar.bz2
- fix-fortify-system-wrappers.patch"
+ fix-fortify-system-wrappers.patch
+ copy-headers.patch
+ pkg-config-version.patch
+ icu-add-bracket.patch"
builddir="$srcdir/mozilla-esr38"
_builddir="$builddir/js/src"
options="!check"
build() {
cd "$_builddir"
- ./configure --prefix=/usr \
+ PYTHON=/usr/bin/python ./configure --prefix=/usr \
--with-system-icu \
--with-system-nspr \
--enable-system-ffi \
@@ -38,8 +41,10 @@ package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install
rm -f "$pkgdir"/usr/lib/*.ajs
- mv "$pkgdir"/usr/lib/pkgconfig/js.pc "$pkgdir"/usr/lib/pkgconfig/mozjs-38.pc
}
sha512sums="fcd2497a60176b8403a1793d1ad0a1c96a0a60217c2d4d7acd0506abf6810892bd51fd113d8f952f92b20032efc539a6b1233d8d124c2eb72d726b0935c04d65 firefox-38.8.0esr.source.tar.bz2
-a4f613ba4e977796fa024824940bbc1d3df549138612bfcdbb643753d54d4d5bfbf601a12f76312a87ecc7ec595ff34ddefb47c2cd1a6e31252c1fa3a263bdae fix-fortify-system-wrappers.patch"
+a4f613ba4e977796fa024824940bbc1d3df549138612bfcdbb643753d54d4d5bfbf601a12f76312a87ecc7ec595ff34ddefb47c2cd1a6e31252c1fa3a263bdae fix-fortify-system-wrappers.patch
+22cc4e4595ddbd7ff037ce5f04755de4156d24921fa57161afbaa6494c795e30b6cfc08e8b999dbcce145c231cc6a3322334134e40f251f514b4688598a75f61 copy-headers.patch
+f3d87ffa7232e7242c4a1bf2762c2d1d4e190e72bd1c15fe223bce2480769bf577021ca799aab9570e3219144fcd9978e97cf8648f0cb7abe379bcabc9b03c4c pkg-config-version.patch
+658df4a957b2e11345dc3caf884d2063b4e492c58f002114d3c8d7b595731cde33d1ad43e02cc2eba4ec0e7a751c3c5bbbf0cacab6ca726f2a1158864b09af8c icu-add-bracket.patch"
diff --git a/testing/mozjs-38/copy-headers.patch b/testing/mozjs-38/copy-headers.patch
new file mode 100644
index 0000000000..7f352a795c
--- /dev/null
+++ b/testing/mozjs-38/copy-headers.patch
@@ -0,0 +1,20 @@
+Description: Copy headers on install instead of symlinking
+Author: Rico Tzschichholz <ricotz@ubuntu.com>
+Forwarded: no
+Last-Update: 2014-10-29
+
+---
+
+Index: b/python/mozbuild/mozbuild/backend/recursivemake.py
+===================================================================
+--- a/python/mozbuild/mozbuild/backend/recursivemake.py
++++ b/python/mozbuild/mozbuild/backend/recursivemake.py
+@@ -796,7 +796,7 @@
+ return
+
+ for source, dest, _ in self._walk_hierarchy(obj, exports):
+- self._install_manifests['dist_include'].add_symlink(source, dest)
++ self._install_manifests['dist_include'].add_copy(source, dest)
+
+ if not os.path.exists(source):
+ raise Exception('File listed in EXPORTS does not exist: %s' % source)
diff --git a/testing/mozjs-38/icu-add-bracket.patch b/testing/mozjs-38/icu-add-bracket.patch
new file mode 100644
index 0000000000..873697d18f
--- /dev/null
+++ b/testing/mozjs-38/icu-add-bracket.patch
@@ -0,0 +1,16 @@
+Add bracket for sed 4.3 compliance
+
+Based on upstream fix by Daniel Stenberg in 09 jan 2017
+See: https://hg.mozilla.org/mozilla-central/rev/ebcbf47a83e7
+
+--- a/js/src/configure 2017-02-21 16:56:42.350105741 -0300
++++ b/js/src/configure 2017-02-21 17:33:13.183493978 -0300
+@@ -15231,7 +15231,7 @@
+ fi
+ fi
+
+- version=`sed -n 's/^[:space:]*#[[:space:]]*define[[:space:]][[:space:]]*U_ICU_VERSION_MAJOR_NUM[[:space:]][[:space:]]*\([0-9][0-9]*\)[[:space:]]*$/\1/p' "$icudir/common/unicode/uvernum.h"`
++ version=`sed -n 's/^[[:space:]]*#[[:space:]]*define[[:space:]][[:space:]]*U_ICU_VERSION_MAJOR_NUM[[:space:]][[:space:]]*\([0-9][0-9]*\)[[:space:]]*$/\1/p' "$icudir/common/unicode/uvernum.h"`
+ if test x"$version" = x; then
+ { echo "configure: error: cannot determine icu version number from uvernum.h header file $lineno" 1>&2; echo "configure: error: cannot determine icu version number from uvernum.h header file $lineno" 1>&5; exit 1; }
+ fi
diff --git a/testing/mozjs-38/pkg-config-version.patch b/testing/mozjs-38/pkg-config-version.patch
new file mode 100644
index 0000000000..34a43d1f6d
--- /dev/null
+++ b/testing/mozjs-38/pkg-config-version.patch
@@ -0,0 +1,22 @@
+Add major version to pkg-config filename.
+Author: Rico Tzschichholz <ricotz@ubuntu.com>
+Forwarded: no
+Last-Update: 2015-05-04
+
+Index: b/js/src/Makefile.in
+===================================================================
+--- a/js/src/Makefile.in
++++ b/js/src/Makefile.in
+@@ -214,10 +214,10 @@
+ $(JS_CONFIG_NAME): js-config
+ cp $^ $@
+
+-$(LIBRARY_NAME).pc: js.pc
++$(JS_LIBRARY_NAME).pc: js.pc
+ cp $^ $@
+
+-install:: $(LIBRARY_NAME).pc
++install:: $(JS_LIBRARY_NAME).pc
+ $(SYSINSTALL) $^ $(DESTDIR)$(libdir)/pkgconfig
+
+ install:: js-config.h