aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-10-18 18:25:54 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-18 18:39:53 +0000
commit823571c4baa75832a6143eff88e0ab14be30a3ad (patch)
tree03cfc554cdb0be4045e9ae47966badd94ceeb429 /testing
parent8ddd19ebf77c0fb29136d21b81033991f46a340c (diff)
downloadaports-823571c4baa75832a6143eff88e0ab14be30a3ad.tar.bz2
aports-823571c4baa75832a6143eff88e0ab14be30a3ad.tar.xz
testing/shorewall-core: uprade to 4.5.21
Diffstat (limited to 'testing')
-rw-r--r--testing/shorewall-core/APKBUILD8
-rw-r--r--testing/shorewall-core/shorewall-no-install-T.patch11
-rw-r--r--testing/shorewall-core/shorewall.initd81
3 files changed, 4 insertions, 96 deletions
diff --git a/testing/shorewall-core/APKBUILD b/testing/shorewall-core/APKBUILD
index 77607fab9a..9006921847 100644
--- a/testing/shorewall-core/APKBUILD
+++ b/testing/shorewall-core/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=shorewall-core
-pkgver=4.5.20
+pkgver=4.5.21
pkgrel=0
pkgdesc="Core libraries for Shorewall"
url="http://www.shorewall.net/"
@@ -35,6 +35,6 @@ package() {
DESTDIR="$pkgdir" ./install.sh || return 1
}
-md5sums="7c9f115f5559f33396e736f9235311b3 shorewall-core-4.5.20.tar.bz2"
-sha256sums="7a3f6502d35a4fccbfaab0181c4c4a62b2aa5d2512f9b2679305e7d541149f47 shorewall-core-4.5.20.tar.bz2"
-sha512sums="bf1c7a87eae6f338fd70457865fcec3b2afb6af394cc263a932465d83d03b2cd3c421149250d67143a8930c263e69854a622cb31a27da3e534e0e4520a20b22d shorewall-core-4.5.20.tar.bz2"
+md5sums="9987b8ba3663ea60465947eda4bcdbb4 shorewall-core-4.5.21.tar.bz2"
+sha256sums="394fde2b56158c72993886ece463a24f3d0eee47a292121a39af2bf936f380cb shorewall-core-4.5.21.tar.bz2"
+sha512sums="090f80b37415d96913a37e3b5b06f173d32ef8cd4bcee3fcbca5d3bb9f7366a039b550663d833f0e72e8a67ad70ea54090256199f55830a7063a9fbe506b3e8f shorewall-core-4.5.21.tar.bz2"
diff --git a/testing/shorewall-core/shorewall-no-install-T.patch b/testing/shorewall-core/shorewall-no-install-T.patch
deleted file mode 100644
index 09567a5123..0000000000
--- a/testing/shorewall-core/shorewall-no-install-T.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/shorewall-4.4.21/install.sh
-+++ b/shorewall-4.4.21/install.sh
-@@ -96,7 +96,7 @@
- # INIT is the name of the script in the $DEST directory
- # ARGS is "yes" if we've already parsed an argument
- #
--T="-T"
-+T=
-
- if [ -z "$DEST" ] ; then
- DEST="/etc/init.d"
diff --git a/testing/shorewall-core/shorewall.initd b/testing/shorewall-core/shorewall.initd
deleted file mode 100644
index 1c5a5f6aee..0000000000
--- a/testing/shorewall-core/shorewall.initd
+++ /dev/null
@@ -1,81 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-common/files/shorewall.initd,v 1.2 2008/05/04 13:16:40 pva Exp $
-
-extra_started_commands="refresh"
-extra_commands="clear reset check"
-
-depend() {
- need net
- provide firewall
- after ulogd
-}
-
-start() {
- ebegin "Starting firewall"
- /sbin/shorewall -f start 1>/dev/null
- eend $?
-}
-
-stop() {
- ebegin "Stopping firewall"
- /sbin/shorewall stop 1>/dev/null
- eend $?
-}
-
-restart() {
- # shorewall comes with its own control script that includes a
- # restart function, so refrain from calling svc_stop/svc_start
- # here. Note that this comment is required to fix bug 55576;
- # runscript.sh greps this script... (09 Jul 2004 agriffis)
- ebegin "Restarting firewall"
- /sbin/shorewall status >/dev/null
- if [ $? != 0 ] ; then
- svc_start
- else
- if [ -f /var/lib/shorewall/restore ] ; then
- /sbin/shorewall restore
- else
- /sbin/shorewall restart 1>/dev/null
- fi
- fi
- eend $?
-}
-
-clear() {
- # clear will remove all the rules and bring the system to an unfirewalled
- # state. (21 Nov 2004 eldad)
-
- ebegin "Clearing all firewall rules and setting policy to ACCEPT"
- /sbin/shorewall clear
- eend $?
-}
-
-reset() {
- # reset the packet and byte counters in the firewall
-
- ebegin "Resetting the packet and byte counters in the firewall"
- /sbin/shorewall reset
- eend $?
-}
-
-refresh() {
- # refresh the rules involving the broadcast addresses of firewall
- # interfaces, the black list, traffic control rules and
- # ECN control rules
-
- ebegin "Refreshing firewall rules"
- /sbin/shorewall refresh
- eend $?
-}
-
-check() {
- # perform cursory validation of the zones, interfaces, hosts, rules
- # and policy files. CAUTION: does not parse and validate the generated
- # iptables commands.
-
- ebegin "Checking configuration files"
- /sbin/shorewall check
- eend $?
-}