aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-04-21 14:42:55 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-04-21 14:44:37 +0000
commit84f1173064d6c9ca783ee1691ed549f8dedc3282 (patch)
tree6a00707cc8931b7ebc9dca1af28bcce02d8071a4 /testing
parent3ae61e4a2c720fd1d1f2b787039196ec05b03e40 (diff)
downloadaports-84f1173064d6c9ca783ee1691ed549f8dedc3282.tar.bz2
aports-84f1173064d6c9ca783ee1691ed549f8dedc3282.tar.xz
community/mongodb-tools: moved from testing
Diffstat (limited to 'testing')
-rw-r--r--testing/mongodb-tools/APKBUILD37
-rw-r--r--testing/mongodb-tools/fix-build.patch13
-rw-r--r--testing/mongodb-tools/libressl.patch21
3 files changed, 0 insertions, 71 deletions
diff --git a/testing/mongodb-tools/APKBUILD b/testing/mongodb-tools/APKBUILD
deleted file mode 100644
index 628ddf4cdb..0000000000
--- a/testing/mongodb-tools/APKBUILD
+++ /dev/null
@@ -1,37 +0,0 @@
-# Contributor: Marc Vertes <marc.vertes@ugrid.net>
-# Maintainer: Marc Vertes <marc.vertes@ugrid.net>
-pkgname=mongodb-tools
-pkgver=r3.4.3
-pkgrel=2
-pkgdesc="The MongoDB tools provide import, export, and diagnostic capabilities."
-url="https://github.com/mongodb/mongo-tools"
-arch="all !aarch64"
-license="apache"
-makedepends="$depends_dev go cyrus-sasl-dev libressl-dev libpcap-dev"
-options="!check"
-source="https://github.com/mongodb/mongo-tools/archive/$pkgver/$pkgname-$pkgver.tar.gz
- libressl.patch
- fix-build.patch
- "
-builddir="$srcdir"/mongo-tools-$pkgver
-
-prepare() {
- cd "$builddir"
- default_prepare
-}
-
-build() {
- cd "$builddir"
- ./build.sh sasl ssl
-}
-
-package() {
- cd "$builddir/bin"
- local bindir="$pkgdir/usr/bin"
- mkdir -p "$bindir" || return 1
- cp bsondump mongostat mongofiles mongoexport mongoimport mongorestore mongodump mongotop mongooplog mongoreplay "$bindir" || return 1
-}
-
-sha512sums="ec754e8b19c517d9603e0eb89cc315e0af53886b74a905c0742faf5369af8b87b84cedf57aaa25f93068cd21370fa8a274a97dc3c58bbb4a50db6c2e4f0109d9 mongodb-tools-r3.4.3.tar.gz
-3e336b01c33da66623cc84bf9c29c794bba20bdaf6299713f39416ed1a92406c6f2e5e03865aaca128f91e8e1ac64c6c52a2a92610c59dc7be2fd6c997e9361e libressl.patch
-74e432b354fd75209b87461e54f79a173ba0d647a2e45a48d520ee9342236b6a50ef1c634312f4804402578b8534d59ebf10973ce90cae2bbe76407102f2b404 fix-build.patch"
diff --git a/testing/mongodb-tools/fix-build.patch b/testing/mongodb-tools/fix-build.patch
deleted file mode 100644
index 4913d8caa6..0000000000
--- a/testing/mongodb-tools/fix-build.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- mongo-tools-r3.4.3/build.sh.orig
-+++ mongo-tools-r3.4.3/build.sh
-@@ -7,8 +7,8 @@
- fi
-
- # make sure we're in the directory where the script lives
--SCRIPT_DIR="$(cd "$(dirname ${BASH_SOURCE[0]})" && pwd)"
--cd $SCRIPT_DIR
-+#SCRIPT_DIR="$(cd "$(dirname ${BASH_SOURCE[0]})" && pwd)"
-+#cd $SCRIPT_DIR
-
- sed -i.bak -e "s/built-without-version-string/$(git describe)/" \
- -e "s/built-without-git-spec/$(git rev-parse HEAD)/" \
diff --git a/testing/mongodb-tools/libressl.patch b/testing/mongodb-tools/libressl.patch
deleted file mode 100644
index 0afd28f98c..0000000000
--- a/testing/mongodb-tools/libressl.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- mongo-tools-r3.4.3.orig/vendor/src/github.com/spacemonkeygo/openssl/cert.go
-+++ mongo-tools-r3.4.3/vendor/src/github.com/spacemonkeygo/openssl/cert.go
-@@ -277,8 +277,8 @@
- md = C.EVP_md_null()
- case EVP_MD5:
- md = C.EVP_md5()
-- case EVP_SHA:
-- md = C.EVP_sha()
-+ //case EVP_SHA:
-+ // md = C.EVP_sha()
- case EVP_SHA1:
- md = C.EVP_sha1()
- case EVP_DSS:
---- mongo-tools-r3.4.3.orig/vendor/src/github.com/spacemonkeygo/openssl/version.go
-+++ mongo-tools-r3.4.3/vendor/src/github.com/spacemonkeygo/openssl/version.go
-@@ -19,4 +19,4 @@
- // #include <openssl/opensslv.h>
- import "C"
-
--const Version string = C.OPENSSL_VERSION_TEXT
-+const Version string = "LibreSSL 2.4.5"