aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-01-30 09:19:52 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2017-01-30 09:30:42 +0100
commit85d8f7ea2953cd45482a8db01caeb4dd07ecebda (patch)
treec29f7e96bc5e55f4b0ae7c98e8f97f1d72397ffa /testing
parent3af95486f1fc3d096880b9c5a8759891b7537e50 (diff)
downloadaports-85d8f7ea2953cd45482a8db01caeb4dd07ecebda.tar.bz2
aports-85d8f7ea2953cd45482a8db01caeb4dd07ecebda.tar.xz
testing/drawterm: fix off by one in devmouse
Diffstat (limited to 'testing')
-rw-r--r--testing/drawterm/APKBUILD11
-rw-r--r--testing/drawterm/fix-off-by-one.patch14
2 files changed, 19 insertions, 6 deletions
diff --git a/testing/drawterm/APKBUILD b/testing/drawterm/APKBUILD
index 985699d9e3..2e6bb9e150 100644
--- a/testing/drawterm/APKBUILD
+++ b/testing/drawterm/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=drawterm
pkgver=20170119
-pkgrel=1
+pkgrel=2
pkgdesc="Connect to Plan 9 CPU servers from other operating systems"
url="http://drawterm.9front.org/"
arch="all !armhf !aarch64"
@@ -12,6 +12,7 @@ makedepends="linux-headers libx11-dev libxt-dev"
install=""
subpackages="$pkgname-dbg"
source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.gz
+ fix-off-by-one.patch
respect-env.patch"
_srcurl="https://code.9front.org/hg/$pkgname"
@@ -34,11 +35,6 @@ snapshot() {
}
build() {
- # Building drawterm with -Os currently causes a
- # segfault after authentication on alpine. Thus
- # disable our own CFLAGS for now.
- unset CFLAGS
-
CONF=unix make X11INC=/usr/include/X11 \
X11LIB=/usr/lib/X11 \
-C "$builddir" || return 1
@@ -54,8 +50,11 @@ package() {
}
md5sums="98d9c8d514802b58cbbac50c52185371 drawterm-20170119.tar.gz
+1583e6505c6bc4f1bc053c4fdcd9aee1 fix-off-by-one.patch
e02b5a0df664a5eec50ad58a79988f9c respect-env.patch"
sha256sums="aa7e170b39ae014d2687ad4dc99941695b02e4515054b6dfccc01a5261e4db7c drawterm-20170119.tar.gz
+236b3bc552e9007b6f9ca1de8dc02072f2863f3dbed7b843d9ead165508480f5 fix-off-by-one.patch
30f15a5b48d5f92107d5bedd28d3d619be8afedcb1063df5a94ca2c2609d632d respect-env.patch"
sha512sums="fec2895bd01940cd91ed6c4b73fd13ec6a55c5a5b2241f48430a73af44e6e4c649819a2ee9feee1880d4bf27ab007a229c6b5170039b73f1f19f8b0e6d04c510 drawterm-20170119.tar.gz
+dc57264470e2ab583c7dfbb6451b9fcea47e37a24bdeb7e512ab50a0321f086b471dbe08b2d13514c7842e084f5fdf078f917a19e62bd6aaceb2e199e8169374 fix-off-by-one.patch
be42c27a550b49f13fa26cdd698fb4d8387d989141cae1a3671deceb82b9286c9f73772ec9731698c7ecef69949381f9eda8af1dc1d9957fa373752e52f809bb respect-env.patch"
diff --git a/testing/drawterm/fix-off-by-one.patch b/testing/drawterm/fix-off-by-one.patch
new file mode 100644
index 0000000000..a1b6d5dc33
--- /dev/null
+++ b/testing/drawterm/fix-off-by-one.patch
@@ -0,0 +1,14 @@
+upstream url: https://code.9front.org/hg/drawterm/rev/fbf56ef73faf
+
+diff -upr drawterm-20170119.orig/kern/devmouse.c drawterm-20170119/kern/devmouse.c
+--- drawterm-20170119.orig/kern/devmouse.c 2017-01-30 09:18:21.250082979 +0100
++++ drawterm-20170119/kern/devmouse.c 2017-01-30 09:18:40.093373597 +0100
+@@ -122,7 +122,7 @@ mouseclose(Chan *c)
+ long
+ mouseread(Chan *c, void *va, long n, vlong offset)
+ {
+- char buf[4*12+1];
++ char buf[1+4*12+1];
+ Mousestate m;
+ uchar *p;
+ int b;