aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorDavid Demelier <markand@malikania.fr>2020-04-06 15:09:09 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-04-06 22:35:25 +0000
commit87e1b96b6029f2504f095fea00e847579858f04d (patch)
tree9813f8c2dbdb474ce411f56c4f3cc2e6b048e267 /testing
parent786ffd26c6d919120be55c6ed9b956946a980761 (diff)
downloadaports-87e1b96b6029f2504f095fea00e847579858f04d.tar.bz2
aports-87e1b96b6029f2504f095fea00e847579858f04d.tar.xz
testing/libretro-openlara: new aport
https://github.com/libretro/OpenLara classic Tomb Raider open-source engine for libretro
Diffstat (limited to 'testing')
-rw-r--r--testing/libretro-openlara/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/libretro-openlara/APKBUILD b/testing/libretro-openlara/APKBUILD
new file mode 100644
index 0000000000..fb3c5e322b
--- /dev/null
+++ b/testing/libretro-openlara/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: David Demelier <markand@malikania.fr>
+# Maintainer: David Demelier <markand@malikania.fr>
+pkgname=libretro-openlara
+pkgver=0_git20200225
+pkgrel=0
+_commit="c7fd002610c551cfbbfa4947ea9c3a2574fe51c5"
+pkgdesc="classic Tomb Raider open-source engine for libretro"
+url="https://github.com/libretro/OpenLara"
+arch="all"
+license="BSD-2-Clause"
+makedepends="mesa-dev"
+source="$pkgname-$_commit.tar.gz::https://github.com/libretro/OpenLara/archive/$_commit.tar.gz"
+builddir="$srcdir/OpenLara-$_commit"
+options="!check" # No tests
+
+build() {
+ make -C src/platform/libretro
+}
+
+package() {
+ install -Dm644 src/platform/libretro/openlara_libretro.so "$pkgdir"/usr/lib/libretro/openlara_libretro.so
+}
+
+sha512sums="64f6faf0a6b751668d7271e82785146a9fee7e66a1878bc13d6c5edb678ae27910d6e2fcd5e8f5d5ecc5a40b6cc3daac48a4242be47c772194c80defb3864ae3 libretro-openlara-c7fd002610c551cfbbfa4947ea9c3a2574fe51c5.tar.gz"