aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorDanilo Bürger <danilo@feastr.de>2015-10-27 20:46:10 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2015-10-28 13:00:36 +0000
commit894f561562b47fc67e496800fe6a04261a7613a0 (patch)
treeb0d76af1b95b578069fb5f87dde168d39ddd764b /testing
parent06dc691e8859ab34af1e988c81f2bae2bc88c9d1 (diff)
downloadaports-894f561562b47fc67e496800fe6a04261a7613a0.tar.bz2
aports-894f561562b47fc67e496800fe6a04261a7613a0.tar.xz
testing/tini: new aport
https://github.com/krallin/tini A tiny but valid init for containers
Diffstat (limited to 'testing')
-rw-r--r--testing/tini/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/tini/APKBUILD b/testing/tini/APKBUILD
new file mode 100644
index 0000000000..ba4cce3762
--- /dev/null
+++ b/testing/tini/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Danilo Bürger <danilo@feastr.de>
+
+pkgname=tini
+pkgver=0.8.0
+pkgrel=0
+pkgdesc="A tiny but valid init for containers"
+url="https://github.com/krallin/tini"
+arch="all"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="$depends_dev cmake"
+install=""
+subpackages=""
+source="$pkgname-$pkgver.tar.gz::https://github.com/krallin/tini/archive/v$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ export CFLAGS="-DPR_SET_CHILD_SUBREAPER=36 -DPR_GET_CHILD_SUBREAPER=37"
+ cmake . || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -D -m755 tini "$pkgdir"/usr/bin/tini || return 1
+}
+
+md5sums="9d8fab8fe911ceb5f9c595840879e7b3 tini-0.8.0.tar.gz"
+sha256sums="06c4df7175bb2f7eb34026c8991c2b6c2b318c473b9f1362d290f453039fd36a tini-0.8.0.tar.gz"
+sha512sums="b2040841ed0522a60150d93d1cdf589b0dfd9704a17e7bd4a891c6dfda2544703447591fc75d518303d2ecfd622821be0cda72212a628e187eb2f4bbb3f8173e tini-0.8.0.tar.gz"