aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2015-11-30 14:21:06 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2015-11-30 14:21:06 +0000
commit8cb7d861abb6d22e25dda7952a87370ff7113653 (patch)
treec08b1f9393d9400fb05e89c94728d7993031255b /testing
parent0802ff9fe40ffe2ab38c6ac1b72290f6c0a632fc (diff)
downloadaports-8cb7d861abb6d22e25dda7952a87370ff7113653.tar.bz2
aports-8cb7d861abb6d22e25dda7952a87370ff7113653.tar.xz
testing/ospd-nmap: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/ospd-nmap/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/testing/ospd-nmap/APKBUILD b/testing/ospd-nmap/APKBUILD
new file mode 100644
index 0000000000..7901a395aa
--- /dev/null
+++ b/testing/ospd-nmap/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=ospd-nmap
+pkgver=1.0b1
+pkgrel=0
+_pkgid=2218
+pkgdesc="OSP server implementation to allow OpenVAS to remotel control nmap port scanner"
+url="http://www.openvas.org/"
+arch="noarch"
+license="GPL"
+depends="python"
+depends_dev=""
+makedepends="$depends_dev cmake py-setuptools"
+install=""
+subpackages=""
+source="http://wald.intevation.org/frs/download.php/$_pkgid/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+
+
+md5sums="15b56da5a7282db6de7d6e534ec064e2 ospd-nmap-1.0b1.tar.gz"
+sha256sums="b3fc890fd13f459a5892cd465811289be61374b988ac6b983b05918f5a94d0ae ospd-nmap-1.0b1.tar.gz"
+sha512sums="f251d0951ba6225844274d26187aa7b90a654ed765471f356fa7979b623c5c04c7f7527dffb9e8f28e278c3e4079a7881947787435779c57d5346520934a9d21 ospd-nmap-1.0b1.tar.gz"