aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-05-09 22:40:52 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-05-10 12:04:10 +0000
commit8ef98f8a70750af3c42031c5356109388dfb3edd (patch)
tree31c6282f4e3632cb990d7a0c4e98f493445d94b9 /testing
parentc57c30740c1fa3334886bb27248aaf49c2c2dd57 (diff)
downloadaports-8ef98f8a70750af3c42031c5356109388dfb3edd.tar.bz2
aports-8ef98f8a70750af3c42031c5356109388dfb3edd.tar.xz
testing/py3-pokebase: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-pokebase/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/py3-pokebase/APKBUILD b/testing/py3-pokebase/APKBUILD
new file mode 100644
index 0000000000..5305edbbd1
--- /dev/null
+++ b/testing/py3-pokebase/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Bart Ribberse <bribbers@disroot.org>
+# Maintainer: Bart Ribberse <bribbers@disroot.org>
+pkgname=py3-pokebase
+pkgver=1.2.0
+pkgrel=0
+pkgdesc="A Python wrapper for the friendly PokeAPI database"
+url="https://github.com/GregHilmes/pokebase"
+arch="noarch"
+license="BSD-3-Clause"
+depends="python3 py3-requests py3-certifi py3-chardet py3-idna py3-urllib3"
+makedepends="py3-setuptools"
+source="https://pypi.python.org/packages/source/p/pokebase/pokebase-$pkgver.tar.gz"
+options="!check" # No tests in pypi package
+builddir="$srcdir/pokebase-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="b6f3e89cb5b95cf6703755526e69ce27e294ef1b7095267e2fd419d0fecd0e7168239319f83d301b2e30f811346275d0cdb7c0a40cf368c90ff31fa503f95ab8 pokebase-1.2.0.tar.gz"