aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorAdeel <adeelbm@outlook.com>2017-09-19 13:55:30 +0300
committerNatanael Copa <ncopa@alpinelinux.org>2017-09-20 09:12:22 +0000
commit90153903d9f07fd3dff9262af8d307ffa20673fe (patch)
tree720a5a4f00871aec1a47cdaaa6ef460016434aa3 /testing
parent6cb5bb5c95360eb19c2721449372eafdc896e400 (diff)
downloadaports-90153903d9f07fd3dff9262af8d307ffa20673fe.tar.bz2
aports-90153903d9f07fd3dff9262af8d307ffa20673fe.tar.xz
testing/lttng-ust: Update lttng-ust to 2.10.0
The patch `testing/lttng-ust/musl-has-no-dlmopen.patch` is not needed anymore. Also added test suite.
Diffstat (limited to 'testing')
-rw-r--r--testing/lttng-ust/APKBUILD17
-rw-r--r--testing/lttng-ust/musl-has-no-dlmopen.patch153
2 files changed, 8 insertions, 162 deletions
diff --git a/testing/lttng-ust/APKBUILD b/testing/lttng-ust/APKBUILD
index 9e25bc9ad4..3d5d47c572 100644
--- a/testing/lttng-ust/APKBUILD
+++ b/testing/lttng-ust/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Michael Jeanson <mjeanson@efficios.com>
# Maintainer: Michael Jeanson <mjeanson@efficios.com>
pkgname=lttng-ust
-pkgver=2.9.0
+pkgver=2.10.0
pkgrel=1
pkgdesc="LTTng 2.0 Userspace Tracer"
url="https://lttng.org"
@@ -12,8 +12,7 @@ depends_dev=""
makedepends="$depends_dev userspace-rcu-dev util-linux-dev linux-headers bash"
install=""
subpackages="$pkgname-dev $pkgname-doc"
-source="https://lttng.org/files/$pkgname/$pkgname-$pkgver.tar.bz2
- musl-has-no-dlmopen.patch"
+source="https://lttng.org/files/$pkgname/$pkgname-$pkgver.tar.bz2"
builddir="$srcdir"/$pkgname-$pkgver
@@ -29,6 +28,11 @@ build() {
make check || return 1
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
@@ -43,9 +47,4 @@ dev() {
rm -rf "$subpkgdir"/usr/share/doc/$pkgname
}
-md5sums="77f3378ba37a36801420bce87b702e9c lttng-ust-2.9.0.tar.bz2
-90cb166ae29bd68b71f016a7d8144853 musl-has-no-dlmopen.patch"
-sha256sums="4d541a863f42dfc685ca05024027a442c70d03594c154a43e62bc109b1ea5daf lttng-ust-2.9.0.tar.bz2
-10011dc0d8c300400c5da86867912f3600d5c40a1d45e20fd6cd544c860b4e85 musl-has-no-dlmopen.patch"
-sha512sums="72cbc167918d7675f86314dd9ecca91bfbf2a0c94e8befecc03633296a3d071049ab9dccd9f75e03e67b95518a8917096652d90c88e0daf17fe6b31b2df28d17 lttng-ust-2.9.0.tar.bz2
-1b5d88ac0fe340b93fe0e1b391e63d069d104bf11e8b418a594a3e50eb6266aea51daeb36dbda8d39b862bd71bce4146c90fd3a9f7b878754b27b676d149f8e8 musl-has-no-dlmopen.patch"
+sha512sums="a1661681d09b08ce4ca25dfad6c42c51a1a82f1647ddb9560b8b369f2ff16b7e07618554e1c81941da6f8d50cec2501611f7f3e89bbafccdfc984434f47ff397 lttng-ust-2.10.0.tar.bz2"
diff --git a/testing/lttng-ust/musl-has-no-dlmopen.patch b/testing/lttng-ust/musl-has-no-dlmopen.patch
deleted file mode 100644
index 3e2fcc0b77..0000000000
--- a/testing/lttng-ust/musl-has-no-dlmopen.patch
+++ /dev/null
@@ -1,153 +0,0 @@
---- ./lttng-ust-2.9.0.orig/liblttng-ust-dl/lttng-ust-dl.c
-+++ lttng-ust-2.9.0/liblttng-ust-dl/lttng-ust-dl.c
-@@ -38,8 +38,6 @@
- #include "ust_dl.h"
-
- static void *(*__lttng_ust_plibc_dlopen)(const char *filename, int flags);
--static void *(*__lttng_ust_plibc_dlmopen)(Lmid_t nsid, const char *filename,
-- int flags);
- static int (*__lttng_ust_plibc_dlclose)(void *handle);
-
- static
-@@ -56,20 +54,6 @@
- }
-
- static
--void *_lttng_ust_dl_libc_dlmopen(Lmid_t nsid, const char *filename,
-- int flags)
--{
-- if (!__lttng_ust_plibc_dlmopen) {
-- __lttng_ust_plibc_dlmopen = dlsym(RTLD_NEXT, "dlmopen");
-- if (!__lttng_ust_plibc_dlmopen) {
-- fprintf(stderr, "%s\n", dlerror());
-- return NULL;
-- }
-- }
-- return __lttng_ust_plibc_dlmopen(nsid, filename, flags);
--}
--
--static
- int _lttng_ust_dl_libc_dlclose(void *handle)
- {
- if (!__lttng_ust_plibc_dlclose) {
-@@ -143,67 +127,6 @@
- return;
- }
-
--static
--void lttng_ust_dl_dlmopen(void *so_base, Lmid_t nsid, const char *so_name,
-- int flags, void *ip)
--{
-- char resolved_path[PATH_MAX];
-- struct lttng_ust_elf *elf;
-- uint64_t memsz;
-- uint8_t *build_id = NULL;
-- size_t build_id_len;
-- char *dbg_file = NULL;
-- uint32_t crc;
-- int has_build_id = 0, has_debug_link = 0;
-- int ret;
--
-- if (!realpath(so_name, resolved_path)) {
-- ERR("could not resolve path '%s'", so_name);
-- return;
-- }
--
-- elf = lttng_ust_elf_create(resolved_path);
-- if (!elf) {
-- ERR("could not acces file %s", resolved_path);
-- return;
-- }
--
-- ret = lttng_ust_elf_get_memsz(elf, &memsz);
-- if (ret) {
-- goto end;
-- }
-- ret = lttng_ust_elf_get_build_id(
-- elf, &build_id, &build_id_len, &has_build_id);
-- if (ret) {
-- goto end;
-- }
-- ret = lttng_ust_elf_get_debug_link(
-- elf, &dbg_file, &crc, &has_debug_link);
-- if (ret) {
-- goto end;
-- }
--
-- tracepoint(lttng_ust_dl, dlmopen,
-- ip, so_base, nsid, resolved_path, flags, memsz,
-- has_build_id, has_debug_link);
--
-- if (has_build_id) {
-- tracepoint(lttng_ust_dl, build_id,
-- ip, so_base, build_id, build_id_len);
-- }
--
-- if (has_debug_link) {
-- tracepoint(lttng_ust_dl, debug_link,
-- ip, so_base, dbg_file, crc);
-- }
--
--end:
-- free(dbg_file);
-- free(build_id);
-- lttng_ust_elf_destroy(elf);
-- return;
--}
--
- void *dlopen(const char *filename, int flags)
- {
- void *handle;
-@@ -221,27 +144,6 @@
- }
- lttng_ust_dl_update(LTTNG_UST_CALLER_IP());
- return handle;
--}
--
--void *dlmopen(Lmid_t nsid, const char *filename, int flags)
--{
-- void *handle;
--
-- handle = _lttng_ust_dl_libc_dlmopen(nsid, filename, flags);
-- if (__tracepoint_ptrs_registered && handle) {
-- struct link_map *p = NULL;
-- int ret;
--
-- ret = dlinfo(handle, RTLD_DI_LINKMAP, &p);
-- if (ret != -1 && p != NULL && p->l_addr != 0) {
-- lttng_ust_dl_dlmopen((void *) p->l_addr,
-- nsid, p->l_name, flags,
-- LTTNG_UST_CALLER_IP());
-- }
-- }
-- lttng_ust_dl_update(LTTNG_UST_CALLER_IP());
-- return handle;
--
- }
-
- int dlclose(void *handle)
---- ./lttng-ust-2.9.0.orig/liblttng-ust-dl/ust_dl.h
-+++ lttng-ust-2.9.0/liblttng-ust-dl/ust_dl.h
-@@ -51,22 +51,6 @@
- )
- )
-
--TRACEPOINT_EVENT(lttng_ust_dl, dlmopen,
-- TP_ARGS(void *, ip, void *, baddr, Lmid_t, nsid,
-- const char *, path, int, flags,
-- uint64_t, memsz, uint8_t, has_build_id,
-- uint8_t, has_debug_link),
-- TP_FIELDS(
-- ctf_integer_hex(void *, baddr, baddr)
-- ctf_integer(uint64_t, memsz, memsz)
-- ctf_integer(Lmid_t, nsid, nsid)
-- ctf_integer_hex(int, flags, flags)
-- ctf_string(path, path)
-- ctf_integer(uint8_t, has_build_id, has_build_id)
-- ctf_integer(uint8_t, has_debug_link, has_debug_link)
-- )
--)
--
- TRACEPOINT_EVENT(lttng_ust_dl, build_id,
- TP_ARGS(
- void *, ip,