aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2018-12-31 11:25:10 +0200
committerTimo Teräs <timo.teras@iki.fi>2018-12-31 11:33:32 +0200
commit906b4999c1d651323240598ad7fd46a65e037d7f (patch)
treeec6a6df71c46939595cf64d395cf9d4701e71b6b /testing
parent9b503d2a381f39ce7343af0f395c70ebfc70ed4b (diff)
downloadaports-906b4999c1d651323240598ad7fd46a65e037d7f.tar.bz2
aports-906b4999c1d651323240598ad7fd46a65e037d7f.tar.xz
testing/lua-resty-string: new aport
String functions for OpenResty https://github.com/openresty/lua-resty-string
Diffstat (limited to 'testing')
-rw-r--r--testing/lua-resty-string/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/lua-resty-string/APKBUILD b/testing/lua-resty-string/APKBUILD
new file mode 100644
index 0000000000..79cf43fb3a
--- /dev/null
+++ b/testing/lua-resty-string/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=lua-resty-string
+pkgver=0.11
+pkgrel=0
+pkgdesc="String functions for OpenResty"
+url="https://github.com/openresty/lua-resty-string"
+arch="noarch"
+license="BSD"
+depends="nginx-mod-http-lua"
+makedepends=""
+checkdepends="perl-utils perl-test-nginx"
+source="$pkgname-$pkgver.tar.gz::https://github.com/openresty/$pkgname/archive/v$pkgver.tar.gz
+ "
+builddir="$srcdir/$pkgname-$pkgver"
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir"/usr/share/lua/common
+ make DESTDIR="$pkgdir" LUA_LIB_DIR="/usr/share/lua/common" install
+}
+
+check() {
+ cd "$builddir"
+ #make test LUA_LIB_DIR="$builddir/tmp"
+}
+
+sha512sums="f1357f5c93a1f0d32f358df2b162e3a2c605cc57ad4e72dd0fdb6a2409f678aa8100f4977d37c717121f629dafb59ab5786982e806f165974f514c34289d92da lua-resty-string-0.11.tar.gz"