aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-07-01 11:18:30 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-07-01 11:18:30 +0000
commit9231365da35bfe61172dcea6eb416866f12712bd (patch)
tree2f91d92fac835f49720062df5bcad2f90ba53dd7 /testing
parenta6abda876f30000bfc005ebafb6a812aa6808f50 (diff)
downloadaports-9231365da35bfe61172dcea6eb416866f12712bd.tar.bz2
aports-9231365da35bfe61172dcea6eb416866f12712bd.tar.xz
testing/libtirpc: disable auth_des completely
It had some unresolved symbols.
Diffstat (limited to 'testing')
-rw-r--r--testing/libtirpc/APKBUILD22
-rw-r--r--testing/libtirpc/libtirpc-no-des.patch38
2 files changed, 54 insertions, 6 deletions
diff --git a/testing/libtirpc/APKBUILD b/testing/libtirpc/APKBUILD
index d77553d5b2..ecac43adc3 100644
--- a/testing/libtirpc/APKBUILD
+++ b/testing/libtirpc/APKBUILD
@@ -1,24 +1,33 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libtirpc
pkgver=0.2.1
-pkgrel=1
+pkgrel=2
pkgdesc="Transport Independent RPC library (SunRPC replacement)"
url="http://libtirpc.sourceforge.net/"
license="GPL2"
depends=
-makedepends="libgssglue-dev heimdal-dev"
+makedepends="libgssglue-dev heimdal-dev autoconf automake libtool"
subpackages="$pkgname-dev $pkgname-doc"
source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2
- nis.h"
+ nis.h
+ libtirpc-no-des.patch"
depends_dev="libgssglue-dev heimdal-dev"
prepare() {
cd "$srcdir"/$pkgname-$pkgver
+ for i in $source; do
+ case $i in
+ *.patch)
+ msg "Applying $i"
+ patch -p1 -i "$srcdir"/$i || return 1
+ ;;
+ esac
+ done
# uclibc does not provide nis.h so provide our own
mkdir src/rpcsvc
cp "$srcdir"/nis.h src/rpcsvc/
- # we dont have nsl
- sed -i -e "/^libtirpc_la_LDFLAGS/s/-lnsl//" src/Makefile.in
+
+ sh bootstrap && libtoolize
}
build() {
@@ -34,4 +43,5 @@ package() {
install -D -m644 doc/etc_netconfig "$pkgdir"/etc/netconfig
}
md5sums="d77eb15f464bf9d6e66259eaf78b2a4e libtirpc-0.2.1.tar.bz2
-082dff1bc78bdcbac6d305c1534fe3c0 nis.h"
+082dff1bc78bdcbac6d305c1534fe3c0 nis.h
+e386d2893527ed313686eca6314d6675 libtirpc-no-des.patch"
diff --git a/testing/libtirpc/libtirpc-no-des.patch b/testing/libtirpc/libtirpc-no-des.patch
new file mode 100644
index 0000000000..8c59de21f8
--- /dev/null
+++ b/testing/libtirpc/libtirpc-no-des.patch
@@ -0,0 +1,38 @@
+--- ./src/Makefile.am.orig
++++ ./src/Makefile.am
+@@ -40,7 +40,7 @@
+ # release number of your package. This is an abuse that only fosters
+ # misunderstanding of the purpose of library versions."
+ #
+-libtirpc_la_LDFLAGS = -lnsl -lpthread -version-info 1:10:0
++libtirpc_la_LDFLAGS = -lpthread -version-info 1:10:0
+
+ libtirpc_la_SOURCES = auth_none.c auth_unix.c authunix_prot.c bindresvport.c clnt_bcast.c \
+ clnt_dg.c clnt_generic.c clnt_perror.c clnt_raw.c clnt_simple.c \
+@@ -50,7 +50,7 @@
+ rpc_callmsg.c rpc_generic.c rpc_soc.c rpcb_clnt.c rpcb_prot.c \
+ rpcb_st_xdr.c svc.c svc_auth.c svc_dg.c svc_auth_unix.c svc_generic.c \
+ svc_raw.c svc_run.c svc_simple.c svc_vc.c getpeereid.c \
+- auth_time.c auth_des.c authdes_prot.c
++ auth_time.c
+
+ ## XDR
+ libtirpc_la_SOURCES += xdr.c xdr_rec.c xdr_array.c xdr_float.c xdr_mem.c xdr_reference.c xdr_stdio.c
+--- ./src/rpc_soc.c.orig
++++ ./src/rpc_soc.c
+@@ -479,6 +479,7 @@
+ (resultproc_t) rpc_wrap_bcast, "udp");
+ }
+
++#if 0
+ /*
+ * Create the client des authentication object. Obsoleted by
+ * authdes_seccreate().
+@@ -511,6 +512,7 @@
+ return (dummy);
+ }
+
++#endif
+ /*
+ * Create a client handle for a unix connection. Obsoleted by clnt_vc_create()
+ */