aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2018-07-17 18:08:15 +0300
committerNatanael Copa <ncopa@alpinelinux.org>2018-07-17 20:24:59 +0000
commit94273a40f73626ff0adf78c172af176b5cb08a04 (patch)
treede996d49a0f10ca053f3549867ce2d5e0349129a /testing
parente1847890f91f118911ea73ed53a89e5f8a416d52 (diff)
downloadaports-94273a40f73626ff0adf78c172af176b5cb08a04.tar.bz2
aports-94273a40f73626ff0adf78c172af176b5cb08a04.tar.xz
testing/py-peewee: modernize
Diffstat (limited to 'testing')
-rw-r--r--testing/py-peewee/APKBUILD19
1 files changed, 5 insertions, 14 deletions
diff --git a/testing/py-peewee/APKBUILD b/testing/py-peewee/APKBUILD
index c46d23135f..2b64aa482a 100644
--- a/testing/py-peewee/APKBUILD
+++ b/testing/py-peewee/APKBUILD
@@ -15,25 +15,16 @@ install=""
subpackages=""
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$_builddir"
- python3 setup.py build || return 1
+ cd "$builddir"
+ python3 setup.py build
}
package() {
- cd "$_builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="68e33d19d63abe9456bde378ef43da665603b7e11eb2a39b51a0af05ec046f832ad435124c02660327d4f6aa4d6064d703d67199013c8716d7b83226a7d9ac09 peewee-3.2.4.tar.gz"