aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-06-27 02:36:21 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-26 22:36:59 -0300
commit94541845ac60cdf7efc53c8d4a8092ebcb4eb1bc (patch)
tree175c52933200db81b447394f0926a7ed88066b80 /testing
parentf4cc7f7f09d085fb36125b2ea2868dc93999e529 (diff)
downloadaports-94541845ac60cdf7efc53c8d4a8092ebcb4eb1bc.tar.bz2
aports-94541845ac60cdf7efc53c8d4a8092ebcb4eb1bc.tar.xz
testing/plasma-desktop: enable more dependencies
makedepends += xf86-input-synaptics depends += qqc2-desktop-style
Diffstat (limited to 'testing')
-rw-r--r--testing/plasma-desktop/APKBUILD42
1 files changed, 39 insertions, 3 deletions
diff --git a/testing/plasma-desktop/APKBUILD b/testing/plasma-desktop/APKBUILD
index 4470e28ce9..92510f2a92 100644
--- a/testing/plasma-desktop/APKBUILD
+++ b/testing/plasma-desktop/APKBUILD
@@ -2,13 +2,49 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-desktop
pkgver=5.16.2
-pkgrel=1
+pkgrel=2
pkgdesc="KDE Plasma Desktop"
arch="all !ppc64le !s390x" # Limited by plasma-workspace -> libksysguard -> qt5-qtwebengine
url='https://www.kde.org/workspaces/plasmadesktop/'
license="GPL-2.0-only AND LGPL-2.1-only"
-depends="kirigami2 plasma-workspace setxkbmap"
-depends_dev="qt5-qtbase-dev qt5-qtdeclarative-dev qt5-qtx11extras-dev qt5-qtsvg-dev kauth-dev plasma-framework-dev ki18n-dev kcmutils-dev knewstuff-dev kdelibs4support-dev knotifications-dev knotifyconfig-dev attica-dev kwallet-dev krunner-dev kglobalaccel-dev kdeclarative-dev kpeople-dev kdbusaddons-dev kactivities-dev kactivities-stats-dev kconfig-dev plasma-workspace-dev kwin-dev kitemmodels-dev kemoticons-dev baloo-dev fontconfig-dev eudev-dev xf86-input-libinput-dev xf86-input-evdev-dev libxkbfile-dev libxcursor-dev libxi-dev"
+depends="kirigami2 plasma-workspace setxkbmap qqc2-desktop-style"
+depends_dev="
+ qt5-qtbase-dev
+ qt5-qtdeclarative-dev
+ qt5-qtx11extras-dev
+ qt5-qtsvg-dev
+ kauth-dev
+ plasma-framework-dev
+ ki18n-dev
+ kcmutils-dev
+ knewstuff-dev
+ kdelibs4support-dev
+ knotifications-dev
+ knotifyconfig-dev
+ attica-dev
+ kwallet-dev
+ krunner-dev
+ kglobalaccel-dev
+ kdeclarative-dev
+ kpeople-dev
+ kdbusaddons-dev
+ kactivities-dev
+ kactivities-stats-dev
+ kconfig-dev
+ plasma-workspace-dev
+ kwin-dev
+ kitemmodels-dev
+ kemoticons-dev
+ baloo-dev
+ fontconfig-dev
+ eudev-dev
+ xf86-input-libinput-dev
+ xf86-input-evdev-dev
+ xf86-input-synaptics-dev
+ libxkbfile-dev
+ libxcursor-dev
+ libxi-dev
+ "
makedepends="$depends_dev extra-cmake-modules kdoctools-dev"
checkdepends="xvfb-run iso-codes"
source="https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz"