aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNathan Johnson <njohnson@ena.com>2016-08-01 15:25:31 -0500
committerJakub Jirutka <jakub@jirutka.cz>2016-08-02 00:54:15 +0200
commit99a531a9641616984efde077cf6c83a6a90d8fd6 (patch)
treee4c407b33cc1536858e1d93ca8abd17814b69803 /testing
parent503d191a3c66c489188d732d1565180a49f5c82f (diff)
downloadaports-99a531a9641616984efde077cf6c83a6a90d8fd6.tar.bz2
aports-99a531a9641616984efde077cf6c83a6a90d8fd6.tar.xz
testing/php5-couchbase: update to 2.2.0
Diffstat (limited to 'testing')
-rw-r--r--testing/php5-couchbase/APKBUILD19
1 files changed, 8 insertions, 11 deletions
diff --git a/testing/php5-couchbase/APKBUILD b/testing/php5-couchbase/APKBUILD
index f0b4952c99..12c0a60e60 100644
--- a/testing/php5-couchbase/APKBUILD
+++ b/testing/php5-couchbase/APKBUILD
@@ -4,23 +4,20 @@ pkgname=php5-couchbase
_pkgreal=couchbase
replaces=php-couchbase
replaces_priority=1
-pkgver=2.1.0
+pkgver=2.2.0
pkgrel=0
pkgdesc="PHP extension couchbase"
url="http://pecl.php.net/package/$_pkgreal"
arch="all"
license="ASL 2.0"
-depends=
+depends=""
pecldepends="php5-dev autoconf"
makedepends="$pecldepends libcouchbase-dev zlib-dev"
-install=""
-subpackages=""
source="http://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
-
-_builddir="$srcdir"/$_pkgreal-$pkgver
+builddir="$srcdir/$_pkgreal-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
phpize || return 1
./configure --prefix=/usr || return 1
make || return 1
@@ -28,12 +25,12 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make INSTALL_ROOT="$pkgdir"/ install || return 1
install -d "$pkgdir"/etc/php5/conf.d || return 1
echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php5/conf.d/$_pkgreal.ini
}
-md5sums="1ee53916bd2e1247882be0ccaf440857 couchbase-2.1.0.tgz"
-sha256sums="30eda3f5afd0d9f4c77b12650163c3490de111e57ad6b20092c95e44e3d60a8d couchbase-2.1.0.tgz"
-sha512sums="39dabf34d03dc476c0092d05355fc7446506d40a06e8d1b999b54dfe3181200b8bd039e2087456deb7263f7cec9dc93f6541a33510fac5b586e24fe68973dc36 couchbase-2.1.0.tgz"
+md5sums="2fc38ba46db959daaadd4387579fdab8 couchbase-2.2.0.tgz"
+sha256sums="6ce11f344bd01df7e8b96894ea3db44e72a273633d67f80dbc130147cc161acc couchbase-2.2.0.tgz"
+sha512sums="8c3e01e6c7e9b8509ac8900678a5fc4a47d8dfd0f31979b2a4c86f0a6ce195645dd60c4eff1b36b070cb3d9c78cd63edf7c9f162dc1c505b3e8d365a72cfd1f3 couchbase-2.2.0.tgz"