aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorTimothy Legge <timlegge@gmail.com>2019-04-20 00:28:46 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-21 15:30:08 +0000
commit9c0b670e37dd1cb11b0f0069145011fd07f3cbbe (patch)
treecee77ad5d9899183e03fa660dc9ddea815aaa5e2 /testing
parentbb087aaa948bc716abbcd3236be2cd350f502dee (diff)
downloadaports-9c0b670e37dd1cb11b0f0069145011fd07f3cbbe.tar.bz2
aports-9c0b670e37dd1cb11b0f0069145011fd07f3cbbe.tar.xz
testing/perl-xml-canonicalizexml: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/perl-xml-canonicalizexml/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/perl-xml-canonicalizexml/APKBUILD b/testing/perl-xml-canonicalizexml/APKBUILD
new file mode 100644
index 0000000000..2b2148b174
--- /dev/null
+++ b/testing/perl-xml-canonicalizexml/APKBUILD
@@ -0,0 +1,33 @@
+# Automatically generated by apkbuild-cpan, template 2
+# Contributor: Timothy Legge <timlegge@gmail.com>
+# Maintainer: Timothy Legge <timlegge@gmail.com>
+pkgname=perl-xml-canonicalizexml
+_pkgreal=XML-CanonicalizeXML
+pkgver=0.10
+pkgrel=0
+pkgdesc="Perl extension for inclusive (1.0 and 1.1) and exclusive canonicalization of XML using libxml2"
+url="https://metacpan.org/release/XML-CanonicalizeXML/"
+arch="all"
+license="GPL PerlArtistic"
+makedepends="libxml2-dev perl-dev"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/S/SJ/SJZASADA/XML-CanonicalizeXML-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="80a724b4bf11b6a69ae245f775735d286a700d4036d086cffbe47b498e486a42a68b1fc41cfa0bfdfe2c019218d4b623af321f98bdf3d9565a54443db7b2698a XML-CanonicalizeXML-0.10.tar.gz"