aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorShiz <hi@shiz.me>2017-04-27 22:06:25 +0000
committerJakub Jirutka <jakub@jirutka.cz>2017-04-28 03:02:30 +0200
commit9d6ec2481c75a3620795360c8fdf2c78b9354df3 (patch)
tree3d3ae3f62cbc7887bdc5b1244f3a35251ab0782d /testing
parent1ccf62eb0d27f63f20055c1458f9a6ba75b6032c (diff)
downloadaports-9d6ec2481c75a3620795360c8fdf2c78b9354df3.tar.bz2
aports-9d6ec2481c75a3620795360c8fdf2c78b9354df3.tar.xz
testing/cargo: upgrade to 0.18.0
Diffstat (limited to 'testing')
-rw-r--r--testing/cargo/APKBUILD8
-rw-r--r--testing/cargo/fix-test-build-auth.patch4
2 files changed, 6 insertions, 6 deletions
diff --git a/testing/cargo/APKBUILD b/testing/cargo/APKBUILD
index 9efda9b3cf..3ee8f4eb41 100644
--- a/testing/cargo/APKBUILD
+++ b/testing/cargo/APKBUILD
@@ -1,12 +1,12 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=cargo
-pkgver=0.17.0
+pkgver=0.18.0
# Git revision of prebuilt Cargo to use for bootstrapping.
_bootstrap_gitrev=6e0c18cccc8b0c06fba8a8d76486f81a792fb420 # 0.16.0
# Git revision of rust-installer (submodule in cargo repo).
_installer_gitrev=4f994850808a572e2cc8d43f968893c8e942e9bf
-pkgrel=3
+pkgrel=0
pkgdesc="The Rust package manager"
url="https://crates.io"
arch="x86_64" # limited by rust pkg
@@ -101,7 +101,7 @@ _mv() {
mv $@
}
-sha512sums="5ea9a382ab48ee714b5cd1412f11ae72c6065913e2ce56cf84fe43f9061fd383f32c16a6525e5400f3fec9c10eaa3e7a149b026ae9c64af0955e91678b032650 cargo-0.17.0.tar.gz
+sha512sums="561d6817555da802e99964daa74550cc47a285903301da12a245bb62e5857c18069d87a520c5cefb62aecfe5561666352d57dca8f75758f81ea82709565577d2 cargo-0.18.0.tar.gz
9ceb4755890ad3ae68ce141231c5114077261e0279d3a9a6208053f8d3386c9198e6b94d6321b456648dd5baa86dfc3ae81df44b67d41b428d11afd6763f0cff rust-installer-4f994850808a572e2cc8d43f968893c8e942e9bf.tar.gz
4df33353b6be1af822220ca03f9ec5a3b6421c9b10ec17b864be586ba495c6210bac70d904b0e0b35eff62ef2c9a681ded526e5cbd37e326dc3146742aa659de cargo-6e0c18cccc8b0c06fba8a8d76486f81a792fb420-x86_64-unknown-linux-musl.tar.gz
-d93f6beeeb6b1207c38ee216f4a9475c7cc5cb11b52e3b52dbd3c4ad4ed5ca19118c1bc4a24c097aaa20e914e1c3d6a972fd438bae2db2d843319915dc4a3609 fix-test-build-auth.patch"
+6a789fc1bf0eb19dde9267a10f7506787d6a4bb8316b09f4dee5da083c0fb0bad87630b238d92ef3aaf114d9a337a87797c8ac427f71c53ac06106925d459ee0 fix-test-build-auth.patch"
diff --git a/testing/cargo/fix-test-build-auth.patch b/testing/cargo/fix-test-build-auth.patch
index 7269f195a6..2fdb50c1c6 100644
--- a/testing/cargo/fix-test-build-auth.patch
+++ b/testing/cargo/fix-test-build-auth.patch
@@ -21,9 +21,9 @@ the same as actually used libgit2...
let mut conn = BufStream::new(server.accept().unwrap().0);
let req = headers(&mut conn);
- let user_agent = if cfg!(windows) {
-- "User-Agent: git/1.0 (libgit2 0.25.0)"
+- "User-Agent: git/1.0 (libgit2 0.25.1)"
- } else {
-- "User-Agent: git/2.0 (libgit2 0.25.0)"
+- "User-Agent: git/2.0 (libgit2 0.25.1)"
- };
conn.write_all(b"\
HTTP/1.1 401 Unauthorized\r\n\