aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorTimothy Legge <timlegge@gmail.com>2020-03-07 21:26:01 +0000
committerRasmus Thomsen <oss@cogitri.dev>2020-03-07 22:44:50 +0100
commit9f40659c06da79919f48f4f83092bb22213efa12 (patch)
treeeaf64a61c68dcccbf35ede5290bc3f724aab4bc7 /testing
parent9e043287db4449e7ee8ad1df90a4c000840cb2a4 (diff)
downloadaports-9f40659c06da79919f48f4f83092bb22213efa12.tar.bz2
aports-9f40659c06da79919f48f4f83092bb22213efa12.tar.xz
testing/perl-http-tiny-mech: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/perl-http-tiny-mech/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/perl-http-tiny-mech/APKBUILD b/testing/perl-http-tiny-mech/APKBUILD
new file mode 100644
index 0000000000..ee443f13ff
--- /dev/null
+++ b/testing/perl-http-tiny-mech/APKBUILD
@@ -0,0 +1,35 @@
+# Automatically generated by apkbuild-cpan, template 3
+# Contributor: Timothy Legge <timlegge@gmail.com>
+# Maintainer: Timothy Legge <timlegge@gmail.com>
+pkgname=perl-http-tiny-mech
+_pkgreal=HTTP-Tiny-Mech
+pkgver=1.001002
+pkgrel=0
+pkgdesc="Wrap a WWW::Mechanize instance in an HTTP::Tiny compatible interface."
+url="https://metacpan.org/release/HTTP-Tiny-Mech/"
+arch="noarch"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl perl-http-message perl-www-mechanize"
+makedepends="perl-dev"
+checkdepends="perl-http-message"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/K/KE/KENTNL/HTTP-Tiny-Mech-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="0791e827924abbf979c677f0f759de6b5942eb7df53e25de83d4f10d87bb4a7c176d7c1d87621c56d22fc1877552f7c927f40896782544ae10410214d364a967 HTTP-Tiny-Mech-1.001002.tar.gz"