aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-05-11 17:06:42 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-05-12 01:25:08 +0000
commita13ee7ea8afab1ff1c36acac3adddbeaf42b3445 (patch)
treeab0c73cc50c0b534186709be3d778fc55a5c549f /testing
parent8f996cf9366dbf017969193445608fc42d5567c6 (diff)
downloadaports-a13ee7ea8afab1ff1c36acac3adddbeaf42b3445.tar.bz2
aports-a13ee7ea8afab1ff1c36acac3adddbeaf42b3445.tar.xz
testing/py3-tmdbv3api: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-tmdbv3api/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/py3-tmdbv3api/APKBUILD b/testing/py3-tmdbv3api/APKBUILD
new file mode 100644
index 0000000000..d9e3a7b953
--- /dev/null
+++ b/testing/py3-tmdbv3api/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=py3-tmdbv3api
+pkgver=1.5.1
+pkgrel=0
+pkgdesc="A lightweight Python library for The Movie Database (TMDb) API"
+url="https://github.com/AnthonyBloomer/tmdbv3api"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+source="https://pypi.python.org/packages/source/t/tmdbv3api/tmdbv3api-$pkgver.tar.gz"
+options="!check" # No tests in Pypi package and API key required
+builddir="$srcdir/tmdbv3api-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="51dc42144be0070c28f43435f80f204fbbf5baca22c7d72212446b21319fb8b0d013d880a7fdb3096aa6ab4d8a6a6adcfab739c4667c7409cdeff4058f56ab29 tmdbv3api-1.5.1.tar.gz"