aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2019-04-24 08:38:35 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-12 05:55:45 +0000
commita3e8d96ebc850711b3e21b9867b8e11881445d72 (patch)
tree2ce2c4cfdcc5c1be2b5638cb74d287ab04ca3415 /testing
parent5d8a0c1b1010449a723c094cc369e5b00abe73e4 (diff)
downloadaports-a3e8d96ebc850711b3e21b9867b8e11881445d72.tar.bz2
aports-a3e8d96ebc850711b3e21b9867b8e11881445d72.tar.xz
testing/clang6: reenable tests
Closes GH-5639
Diffstat (limited to 'testing')
-rw-r--r--testing/clang6/APKBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/testing/clang6/APKBUILD b/testing/clang6/APKBUILD
index ed48c13dda..5d0810a454 100644
--- a/testing/clang6/APKBUILD
+++ b/testing/clang6/APKBUILD
@@ -4,13 +4,12 @@ _pkgname=clang
pkgver=6.0.1
_majorver=${pkgver%%.*}
pkgname=$_pkgname$_majorver
-pkgrel=0
+pkgrel=1
_llvmver=${pkgver%%.*}
pkgdesc="A C language family front-end for LLVM"
arch="all"
url="https://clang.llvm.org/"
license="UOI-NCSA"
-options="!check" # tests need python lit
makedepends="
cmake
isl-dev
@@ -55,7 +54,7 @@ build() {
-DLIBCLANG_BUILD_STATIC=ON \
-DLLVM_ENABLE_EH=ON \
-DLLVM_ENABLE_RTTI=ON \
- -DLLVM_EXTERNAL_LIT=/usr/lib/llvm6/bin/lit \
+ -DLLVM_EXTERNAL_LIT=/usr/lib/llvm$_llvmver/bin/lit \
-DLLVM_CONFIG=/usr/bin/llvm6-config
make clang-tblgen
@@ -65,7 +64,7 @@ build() {
check() {
cd "$builddir"/build
- make check-clang
+ lit -sv --param clang_site_config=$builddir/build/test/lib.site.cfg $builddir/build/test
}
package() {