aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2020-05-02 11:02:48 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2020-05-02 11:04:17 +0000
commita4bc5133f38d376b234160b621dfc21e61330838 (patch)
tree33dcd82a4cd1dea5703232a643bdcaa97aab34cc /testing
parent1938283e2c5c033b7b9beabd5a34b6c5b8da46aa (diff)
downloadaports-a4bc5133f38d376b234160b621dfc21e61330838.tar.bz2
aports-a4bc5133f38d376b234160b621dfc21e61330838.tar.xz
testing/openscap: udpate patch for PATH_MAX on ppcl64 arch
Diffstat (limited to 'testing')
-rw-r--r--testing/openscap/APKBUILD2
-rw-r--r--testing/openscap/fix-ppc64le-path_max.patch12
2 files changed, 13 insertions, 1 deletions
diff --git a/testing/openscap/APKBUILD b/testing/openscap/APKBUILD
index 5712aeb41b..895f0ab8fa 100644
--- a/testing/openscap/APKBUILD
+++ b/testing/openscap/APKBUILD
@@ -52,5 +52,5 @@ bashcomp() {
}
sha512sums="e230668cdf900a2f31ccabc20787dce6c4174740aa7d2cc7b91c1c095e2a5b73d81bb614aa767d2e51383b5472def360c4204e9a6c4c85110c58b9999566613e openscap-1.3.3.tar.gz
-70bcc718e473862ecac22752ad553c5a520e42207688960403e3d7b9caefc7868fc4d81379a07d3c50fdd9373caab5ac91f758f306d1e3d2bbf355618674b611 fix-ppc64le-path_max.patch
+cd39ed6fa2f50620cad2881497ddc8b012b4641f90799324fdcb9ad8e6901d4065f03be607d858e48466fb5a0ba61815be66f93359763200c33a44b4d2e99ad7 fix-ppc64le-path_max.patch
f2157d6b1d31affe16edb184a287b69d28808123f1cc26a5a4238040d935517b307772b1f2d66271b8ee99b59a4d204930f9147b78478c83c36c7fc8718ec1d9 path_mounted.patch"
diff --git a/testing/openscap/fix-ppc64le-path_max.patch b/testing/openscap/fix-ppc64le-path_max.patch
index 7636391803..1810966f06 100644
--- a/testing/openscap/fix-ppc64le-path_max.patch
+++ b/testing/openscap/fix-ppc64le-path_max.patch
@@ -8,3 +8,15 @@
#include "_seap.h"
#include "probe-api.h"
+diff --git a/src/OVAL/probes/unix/process58_probe.c b/src/OVAL/probes/unix/process58_probe.c
+index 95ef0a7..3ab2cb0 100644
+--- a/src/OVAL/probes/unix/process58_probe.c
++++ b/src/OVAL/probes/unix/process58_probe.c
+@@ -67,6 +67,7 @@
+ #include <fcntl.h>
+ #include <sched.h>
+ #include <time.h>
++#include <limits.h>
+
+ #ifdef HAVE_PROC_DEVNAME_H
+ #include <proc/devname.h>