aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorCharles Pritchard <chuck@jumis.com>2019-07-17 23:02:28 -0700
committerLeo <thinkabit.ukim@gmail.com>2019-07-22 06:49:02 -0300
commita65b512cdca74f71535f3fc459a24042860d65d7 (patch)
tree7dcbf4c31f112354f96eebc7d104ab4a29f2ff26 /testing
parent3753b9e3f39d049e7c6c6664bbed67a0f2bef958 (diff)
downloadaports-a65b512cdca74f71535f3fc459a24042860d65d7.tar.bz2
aports-a65b512cdca74f71535f3fc459a24042860d65d7.tar.xz
testing/py3-biopython: new aport
http://biopython.org/ Python tools for computational molecular biology.
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-biopython/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py3-biopython/APKBUILD b/testing/py3-biopython/APKBUILD
new file mode 100644
index 0000000000..f88c2f4a14
--- /dev/null
+++ b/testing/py3-biopython/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Charles Pritchard <chuck@jumis.com>
+# Maintainer: Charles Pritchard <chuck@jumis.com>
+pkgname=py3-biopython
+_pkgname=biopython
+pkgver=1.74
+pkgrel=0
+pkgdesc="Python tools for computational molecular biology."
+options="!check" # test_NCBI_qblast hangs
+url="https://biopython.org/"
+arch="all"
+license="BSD-3-Clause"
+depends="py3-numpy python3"
+makedepends="py3-setuptools py-numpy-dev python3-dev"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="a5611b993e383d76d2fdc9be22481624180748f06f107e603a062c51b7ca7cf8603d6d97e11d64cd011ae7bd2696c8bf3659b9c625c84c479164a6171d5e8415 biopython-1.74.tar.gz"