aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-31 04:02:07 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-31 04:24:58 -0300
commitaa8588fa12e77adab40c3fcb4d813da7a26bf0c9 (patch)
treeb93fbe769e161b3bd4faef6fb2ab3666b64f5809 /testing
parent270b203fe53421de936b07375039db774fe8e737 (diff)
downloadaports-aa8588fa12e77adab40c3fcb4d813da7a26bf0c9.tar.bz2
aports-aa8588fa12e77adab40c3fcb4d813da7a26bf0c9.tar.xz
testing/py3-deprecated: new aport
https://github.com/tantale/deprecated @deprecated decorator to deprecate old python classes, functions or methods.
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-deprecated/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-deprecated/APKBUILD b/testing/py3-deprecated/APKBUILD
new file mode 100644
index 0000000000..3da61b4f6d
--- /dev/null
+++ b/testing/py3-deprecated/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-deprecated
+pkgver=1.2.6
+pkgrel=0
+pkgdesc="@deprecated decorator to deprecate old python classes, functions or methods."
+url="https://github.com/tantale/deprecated"
+arch="noarch"
+license="MIT"
+depends="python3 py3-wrapt<2"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest py3-pytest-cov"
+source="$pkgname-$pkgver.tar.gz::https://github.com/tantale/deprecated/archive/v$pkgver.tar.gz"
+builddir="$srcdir/deprecated-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 -m pytest
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="fcef322c6d9c317081dae365d469d4b26b0d23d8290e7aa0ca18592fb098ae7f535cb5e898cc81e5c734e7e211c847cdd9d5430c1999a4b9612f30934243ee9e py3-deprecated-1.2.6.tar.gz"