aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <b@bpiotrowski.pl>2012-07-09 09:47:32 +0200
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2012-07-09 09:47:32 +0200
commitab0b0d02245a80ba407b3825e390afaefa2c9e82 (patch)
tree99851a8b3783661e68e1fadc71cc196a251e7de8 /testing
parent5ccdc422ed45059a3afc57f00e52f6c863500310 (diff)
downloadaports-ab0b0d02245a80ba407b3825e390afaefa2c9e82.tar.bz2
aports-ab0b0d02245a80ba407b3825e390afaefa2c9e82.tar.xz
main/xmlrpc-c: moved from testing
Diffstat (limited to 'testing')
-rw-r--r--testing/xmlrpc-c/APKBUILD56
-rw-r--r--testing/xmlrpc-c/xmlrpc-c-curl.patch36
2 files changed, 0 insertions, 92 deletions
diff --git a/testing/xmlrpc-c/APKBUILD b/testing/xmlrpc-c/APKBUILD
deleted file mode 100644
index 5be55ac008..0000000000
--- a/testing/xmlrpc-c/APKBUILD
+++ /dev/null
@@ -1,56 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=xmlrpc-c
-pkgver=1.16.40
-pkgrel=0
-pkgdesc="This library provides a modular implementation of XML-RPC for C and C++"
-url="http://xmlrpc-c.sourceforge.net/"
-arch="all"
-license="custom:xmlrpc-c"
-depends=
-makedepends="libtool curl-dev libxml2-dev zlib-dev"
-subpackages="$pkgname-dev $pkgname-doc xmlrpc-c++:cxx"
-source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tgz
- xmlrpc-c-curl.patch"
-
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- ./configure --prefix=/usr \
- --mandir=/usr/share/man \
- --enable-libxml2-backend \
- --disable-cgi-server \
- --disable-abyss-server \
- --disable-libwww-client \
- --disable-wininet-client
- # no parallel builds :-(
- make -C include &&\
- make -C lib &&\
- make -j1 -C src &&\
- make
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
- install -m 644 -D doc/COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
- rm -f "$pkgdir"/usr/lib/*.la
-}
-
-cxx() {
- pkgdesc="This library provides a modular implementation of XML-RPC for C++"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/*++* "$subpkgdir"/usr/lib/
-}
-
-md5sums="0b5c026d48c21937261d90bdadda7248 xmlrpc-c-1.16.40.tgz
-101c2224b2338247097f96b03e206261 xmlrpc-c-curl.patch"
diff --git a/testing/xmlrpc-c/xmlrpc-c-curl.patch b/testing/xmlrpc-c/xmlrpc-c-curl.patch
deleted file mode 100644
index bfc1145776..0000000000
--- a/testing/xmlrpc-c/xmlrpc-c-curl.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff --git a/lib/curl_transport/curlmulti.c b/lib/curl_transport/curlmulti.c
-index 526a4db..5503b9f 100644
---- a/lib/curl_transport/curlmulti.c
-+++ b/lib/curl_transport/curlmulti.c
-@@ -17,7 +17,6 @@
- #endif
-
- #include <curl/curl.h>
--#include <curl/types.h>
- #include <curl/easy.h>
- #include <curl/multi.h>
-
-diff --git a/lib/curl_transport/curltransaction.c b/lib/curl_transport/curltransaction.c
-index 37ec02b..8fa4fb2 100644
---- a/lib/curl_transport/curltransaction.c
-+++ b/lib/curl_transport/curltransaction.c
-@@ -15,7 +15,6 @@
- #include "version.h"
-
- #include <curl/curl.h>
--#include <curl/types.h>
- #include <curl/easy.h>
-
- #include "curlversion.h"
-diff --git a/lib/curl_transport/xmlrpc_curl_transport.c b/lib/curl_transport/xmlrpc_curl_transport.c
-index 526381d..9b7b530 100644
---- a/lib/curl_transport/xmlrpc_curl_transport.c
-+++ b/lib/curl_transport/xmlrpc_curl_transport.c
-@@ -83,7 +83,6 @@
- #include "xmlrpc-c/time_int.h"
-
- #include <curl/curl.h>
--#include <curl/types.h>
- #include <curl/easy.h>
- #include <curl/multi.h>
-