aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-28 01:17:34 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-28 01:17:34 +0000
commitab8d17cfcf83b89aac7964036a8f55ae0e6a9aa4 (patch)
tree13c90059e62d7add0f47cb71425b46ef4b55db4e /testing
parentb61be416174a86e682b2fa451cf4805b534f9f47 (diff)
downloadaports-ab8d17cfcf83b89aac7964036a8f55ae0e6a9aa4.tar.bz2
aports-ab8d17cfcf83b89aac7964036a8f55ae0e6a9aa4.tar.xz
testing/pylint: fix build
Diffstat (limited to 'testing')
-rw-r--r--testing/pylint/APKBUILD13
1 files changed, 3 insertions, 10 deletions
diff --git a/testing/pylint/APKBUILD b/testing/pylint/APKBUILD
index 385f18f34d..90b07ecf53 100644
--- a/testing/pylint/APKBUILD
+++ b/testing/pylint/APKBUILD
@@ -11,26 +11,19 @@ depends="python py-astroid"
depends_dev=""
makedepends="python-dev py-setuptools py-astroid"
install=""
-subpackages="$pkgname-doc"
source="https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz"
-_builddir="$srcdir"/$pkgname-$pkgver
+builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
python setup.py build || return 1
}
package() {
- cd "$_builddir"
+ cd "$builddir"
python setup.py install --prefix=/usr --root="$pkgdir" || return 1
}
-doc() {
- # The man page is not picked-up automatically
- mkdir -p "$subpkgdir"/usr/share/man/man1 || return 1
- mv "$_builddir"/man/*.1 "$subpkgdir"/usr/share/man/man1/ || return 1
-}
-
md5sums="5924c1c7ca5ca23647812f5971d0ea44 pylint-1.4.3.tar.gz"
sha256sums="1dce8c143a5aa15e0638887c2b395e2e823223c63ebaf8d5f432a99e44b29f60 pylint-1.4.3.tar.gz"
sha512sums="63af8c72496b88db967c61d5be2b974fca053a45425ea8b5898e941be135d26c8c004b91b8b3a98337c0c5af4f5a530afbf091d7c5ecfa36bfa36aef9f843a95 pylint-1.4.3.tar.gz"