aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-06-25 11:19:08 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-06-25 11:22:11 +0000
commitabf73e8bd980c6583c1ab78aca588c160a5e2b56 (patch)
tree01c5e6f504df3e7e2d955bd8867d0fc28412c458 /testing
parentec60b556394451b4e3b6c1d4cd1db648f647dd53 (diff)
downloadaports-abf73e8bd980c6583c1ab78aca588c160a5e2b56.tar.bz2
aports-abf73e8bd980c6583c1ab78aca588c160a5e2b56.tar.xz
testing/libowfat: new aport
reimplementation of libdjb http://www.fefe.de/libowfat/
Diffstat (limited to 'testing')
-rw-r--r--testing/libowfat/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/libowfat/APKBUILD b/testing/libowfat/APKBUILD
new file mode 100644
index 0000000000..8e3ee0eca0
--- /dev/null
+++ b/testing/libowfat/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libowfat
+pkgver=0.28
+pkgrel=0
+pkgdesc="reimplementation of libdjb"
+url="http://www.fefe.de/libowfat/"
+license="GPL"
+depends=
+makedepends=
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://dl.fefe.de/libowfat-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make prefix="$pkgdir"/usr MAN3DIR="$pkgdir"/usr/share/man/man3 install
+ # buffer manpage conflicts with openssl
+ mv "$pkgdir"/usr/share/man/man3/buffer.3 \
+ "$pkgdir"/usr/share/man/man3/owfatbuffer.3
+}
+
+md5sums="6bbee9a86506419657d87123b7a6f2c1 libowfat-0.28.tar.bz2"