aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-01-20 10:49:00 +0200
committerTimo Teräs <timo.teras@iki.fi>2017-01-20 11:06:08 +0200
commitb01972b7d6aa78e8f5a7fc304d01dbbd2447086f (patch)
treefa1090f65445939e0337dad82819f9f3837e9b99 /testing
parent0b54f4b62dd86d5978399e728d23204eaa690384 (diff)
downloadaports-b01972b7d6aa78e8f5a7fc304d01dbbd2447086f.tar.bz2
aports-b01972b7d6aa78e8f5a7fc304d01dbbd2447086f.tar.xz
testing/plymouth: moved from unmaintaned, update
- upgrade to latest version - modernize aports - split more packages - take maintainership
Diffstat (limited to 'testing')
-rw-r--r--testing/plymouth/APKBUILD58
-rw-r--r--testing/plymouth/plymouth-rpmatch.patch17
2 files changed, 75 insertions, 0 deletions
diff --git a/testing/plymouth/APKBUILD b/testing/plymouth/APKBUILD
new file mode 100644
index 0000000000..f94be44cb4
--- /dev/null
+++ b/testing/plymouth/APKBUILD
@@ -0,0 +1,58 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=plymouth
+pkgver=0.9.2
+pkgrel=0
+pkgdesc="graphical bootsplash on linux"
+url="http://www.freedesktop.org/wiki/Software/Plymouth"
+arch="all"
+license="GPL"
+depends=""
+depends_dev="pango-dev
+ gtk+3.0-dev
+ libpng-dev
+ libdrm-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-themes $pkgname-x11:_render $pkgname-drm:_render"
+source="http://www.freedesktop.org/software/plymouth/releases/plymouth-$pkgver.tar.bz2
+ plymouth-rpmatch.patch"
+
+builddir="$srcdir"/plymouth-$pkgver
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --with-system-root-install \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+
+ rm -f "$pkgdir"/usr/lib/plymouth/*.la
+}
+
+themes() {
+ mkdir -p "$subpkgdir"/usr/share/plymouth/
+ mv "$pkgdir"/usr/share/plymouth/themes/ "$subpkgdir"/usr/share/plymouth/
+}
+
+_render() {
+ local _name=${subpkgname#${pkgname}-}
+ mkdir -p "$subpkgdir"/usr/lib/plymouth/renderers
+ mv "$pkgdir"/usr/lib/plymouth/renderers/$_name.so "$subpkgdir"/usr/lib/plymouth/renderers
+}
+
+md5sums="ff420994deb7ea203df678df92e7ab7d plymouth-0.9.2.tar.bz2
+7d342aa2f011833647f1c696007b190c plymouth-rpmatch.patch"
+sha256sums="2f0ce82042cf9c7eadd2517a1f74c8a85fa8699781d9f294a06eade29fbed57f plymouth-0.9.2.tar.bz2
+2281bffcd64de8c2e675656d21b26b0a74fa997af52e941fe6f356d8d4362e37 plymouth-rpmatch.patch"
+sha512sums="89356eb8326504fbf3155de262ce15de0847f0a0e6d157d873cf1dea9af464a6cb9e11d7143ee9a595b217a2487060b5835eba5ac142c3cd6d66689deb272e60 plymouth-0.9.2.tar.bz2
+ec1c32ddf7ee418ef1b5d173040db464193d9bca3fd85d5c3a8d2ee13ba1218947f7c9f39c403d3ccced70be28b2c7328e82dc8f967e9bdeea1651dee4be2dc7 plymouth-rpmatch.patch"
diff --git a/testing/plymouth/plymouth-rpmatch.patch b/testing/plymouth/plymouth-rpmatch.patch
new file mode 100644
index 0000000000..f6e1948747
--- /dev/null
+++ b/testing/plymouth/plymouth-rpmatch.patch
@@ -0,0 +1,17 @@
+--- plymouth-0.8.3.orig/src/libply/ply-command-parser.c
++++ plymouth-0.8.3/src/libply/ply-command-parser.c
+@@ -671,6 +671,14 @@
+ return argument[0] == '-' && argument[1] == '-';
+ }
+
++static inline int
++rpmatch (const char *response)
++{
++ /* Test against "^[yY]" and "^[nN]", hardcoded to avoid requiring regex */
++ return (*response == 'y' || *response == 'Y' ? 1
++ : *response == 'n' || *response == 'N' ? 0 : -1);
++}
++
+ static bool
+ ply_command_option_read_arguments (ply_command_option_t *option,
+ ply_list_t *arguments)