aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-07-28 15:27:13 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-07-28 15:27:13 +0000
commitb12a4c6f467e2fedd31b8086fc0b6e4ae829dccf (patch)
tree9a39815395c59f1a8085ab04f0471187b76c4d1b /testing
parent7aa43af55f54c54868ace5007ff4bde1d6ab1fe6 (diff)
downloadaports-b12a4c6f467e2fedd31b8086fc0b6e4ae829dccf.tar.bz2
aports-b12a4c6f467e2fedd31b8086fc0b6e4ae829dccf.tar.xz
testing/perl-test-yaml: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/perl-test-yaml/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/testing/perl-test-yaml/APKBUILD b/testing/perl-test-yaml/APKBUILD
new file mode 100644
index 0000000000..fa0f0c6f01
--- /dev/null
+++ b/testing/perl-test-yaml/APKBUILD
@@ -0,0 +1,42 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=perl-test-yaml
+_pkgreal=Test-YAML
+pkgver=1.06
+pkgrel=0
+pkgdesc="Testing Module for YAML Implementations"
+url="http://search.cpan.org/dist/Test-YAML/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends="perl-test-base"
+cpanmakedepends=" "
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/I/IN/INGY/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ default_prepare || return 1
+
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make && make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="92e6ea57576428095fe3c9b8e00e6f29 Test-YAML-1.06.tar.gz"
+sha256sums="27376103163c12d7d13ae45bf22caf5a0c38478362425bf68613c3748f76b943 Test-YAML-1.06.tar.gz"
+sha512sums="f6fe4bf46a8cc5ea92b5275cc704e79266b11769bd476888b202540a6d9a23a59a2550503afd88a72f9832355e2b48983f6a31f60db07abe5b0e15f4e74ae2e2 Test-YAML-1.06.tar.gz"