aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-07 00:26:27 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-03-07 01:33:56 +0100
commitb163afa05dc3b21613988cc9185836c29f19cfe7 (patch)
treee4a94562809d747187c9e466809c23bd6a7c02fb /testing
parent26a07eef076ecd6cfc92798879553c1b1e74799e (diff)
downloadaports-b163afa05dc3b21613988cc9185836c29f19cfe7.tar.bz2
aports-b163afa05dc3b21613988cc9185836c29f19cfe7.tar.xz
testing/ocaml-result: remove -doc subpkg and fix comments
Diffstat (limited to 'testing')
-rw-r--r--testing/ocaml-result/APKBUILD20
1 files changed, 7 insertions, 13 deletions
diff --git a/testing/ocaml-result/APKBUILD b/testing/ocaml-result/APKBUILD
index 20943f7987..9c8f177974 100644
--- a/testing/ocaml-result/APKBUILD
+++ b/testing/ocaml-result/APKBUILD
@@ -3,14 +3,14 @@
pkgname=ocaml-result
_pkgname=result
pkgver=1.3
-pkgrel=1
+pkgrel=2
pkgdesc="Compat result type"
url="https://github.com/janestreet/result"
arch="all !x86 !armhf !s390x" # limited by ocaml
license="BSD-3-Clause"
makedepends="dune ocaml ocaml-findlib opam"
options="!check" # no tests provided
-subpackages="$pkgname-dev $pkgname-doc"
+subpackages="$pkgname-dev"
source="https://github.com/janestreet/$_pkgname/archive/$pkgver/$pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -27,28 +27,22 @@ package() {
--destdir="$pkgdir/usr" \
--libdir="$pkgdir/usr/lib/ocaml"
- cd "$pkgdir"
+ # Remove annotation files.
+ rm "$pkgdir"/usr/lib/ocaml/$_pkgname/*.cmt
- # Remove compiled tests.
- rm usr/lib/ocaml/$_pkgname/*.cmt
-
- # Move docs to proper location.
- mkdir -p usr/share/doc
- mv usr/doc/$_pkgname usr/share/doc/$pkgname
- rmdir usr/doc
+ # Contains just a readme and changelog.
+ rm -Rf "$pkgdir"/usr/doc
}
dev() {
default_dev
-
depends="$pkgname=$pkgver-r$pkgrel"
local sitelib="usr/lib/ocaml/$_pkgname"
cd "$pkgdir"/$sitelib
- # May not be created if native compiler is N/A for this platform.
mkdir -p "$subpkgdir"/$sitelib
- mv *.cmx *.cmxa *.ml "$subpkgdir"/$sitelib/ || true
+ mv *.cmx *.cmxa *.ml "$subpkgdir"/$sitelib/
}
sha512sums="eb65e5c3e122db1bb477169d83efc7e02b0c72d3ffdb0cdadf7fc92e28c4e3843d8a0ed28133641cbcb239236fa5c83144610c5de713db5c8f63d9f433d37ba9 ocaml-result-1.3.tar.gz"