aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-05-22 21:55:32 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2016-05-23 15:48:27 +0000
commitb3d55b393833c59586e506d8d937a02b358d0ffe (patch)
tree3f19e4940cafd196497cd93a5ef927b44c9514cb /testing
parent3b8610e30f07f9e4a9b4e3b493a3c9e69552ce4f (diff)
downloadaports-b3d55b393833c59586e506d8d937a02b358d0ffe.tar.bz2
aports-b3d55b393833c59586e506d8d937a02b358d0ffe.tar.xz
testing/qemu-init-script: new abuild
https://github.com/jirutka/qemu-openrc OpenRC init script for QEMU/KVM
Diffstat (limited to 'testing')
-rw-r--r--testing/qemu-init-script/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/qemu-init-script/APKBUILD b/testing/qemu-init-script/APKBUILD
new file mode 100644
index 0000000000..ae34312d60
--- /dev/null
+++ b/testing/qemu-init-script/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=qemu-init-script
+_pkgname=qemu-openrc
+pkgver=0.3.0
+pkgrel=0
+pkgdesc="OpenRC init script for QEMU/KVM"
+url="https://github.com/jirutka/qemu-openrc"
+arch="noarch"
+license="MIT"
+depends="qemu socat"
+makedepends=""
+source="$_pkgname-$pkgver.tar.gz::https://github.com/jirutka/$_pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ return 0
+}
+
+package() {
+ cd "$builddir"
+ PREFIX="/usr" DESTDIR="$pkgdir" ./install
+}
+
+md5sums="fad154543b9583280ce32ef80bfcf7ed qemu-openrc-0.3.0.tar.gz"
+sha256sums="d1556f96d978dc9174c45670fe7a92ece2f4fb1bf2927e6ac0c4b7b3a7ccd068 qemu-openrc-0.3.0.tar.gz"
+sha512sums="ec4abe9b2c55474a8424bffd8f2f5528d7fa4f307f3205f925c7848e4a22862dfa4cb6d831feeac907323082466ff417596043af6588abc005c50e7ee976b153 qemu-openrc-0.3.0.tar.gz"