aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-07-12 15:17:00 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-07-12 15:18:17 +0000
commitb60f851d3fe597d35577b3ddde1638927dbf3a85 (patch)
tree50fe13178b5bb0e2c7c7584894c35af27f422e6a /testing
parenta93e48163ad8c5fec92450470716e5f375910bc8 (diff)
downloadaports-b60f851d3fe597d35577b3ddde1638927dbf3a85.tar.bz2
aports-b60f851d3fe597d35577b3ddde1638927dbf3a85.tar.xz
testing/perl-business-isbn: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/perl-business-isbn/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/testing/perl-business-isbn/APKBUILD b/testing/perl-business-isbn/APKBUILD
new file mode 100644
index 0000000000..c0e3799d66
--- /dev/null
+++ b/testing/perl-business-isbn/APKBUILD
@@ -0,0 +1,42 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=perl-business-isbn
+_pkgreal=Business-ISBN
+pkgver=2.011
+pkgrel=0
+pkgdesc="work with International Standard Book Numbers"
+url="http://search.cpan.org/dist/Business-ISBN/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends="perl-mojolicious perl-business-isbn-data perl-uri"
+cpanmakedepends="perl-business-isbn-data"
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/B/BD/BDFOY/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ default_prepare || return 1
+
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make && make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="713eee9ccc81bd503b8263b34be0164f Business-ISBN-2.011.tar.gz"
+sha256sums="22476441e0f3159542e80eb9ffec2d18725e1412def66e59a7de8caa347bf166 Business-ISBN-2.011.tar.gz"
+sha512sums="4f47d1031739bd45e864c5fda4c8bd346305dbec8e848767003c39f588ccb0ee949a364d49fd6ff44d1a2b5f338a72120d4ab2cbf5bdd12a9f1e9051be05ade2 Business-ISBN-2.011.tar.gz"