aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-10-21 08:01:38 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-10-21 09:51:16 -0300
commitbee99210626400d3d67d0d040f6b4d67f30d3999 (patch)
treea8178c2eb785d4e8dc5bcf1d0e6d4c1ae6229c07 /testing
parent017466bb2e31bc7d2c5350b8202dc89ebc74cf9f (diff)
downloadaports-bee99210626400d3d67d0d040f6b4d67f30d3999.tar.bz2
aports-bee99210626400d3d67d0d040f6b4d67f30d3999.tar.xz
testing/stgit: upgrade to 0.20
Diffstat (limited to 'testing')
-rw-r--r--testing/stgit/APKBUILD48
1 files changed, 43 insertions, 5 deletions
diff --git a/testing/stgit/APKBUILD b/testing/stgit/APKBUILD
index a9755c7301..28fd00228f 100644
--- a/testing/stgit/APKBUILD
+++ b/testing/stgit/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Joseph Benden <joe@benden.us>
pkgname=stgit
-pkgver=0.19
+pkgver=0.20
pkgrel=0
pkgdesc="Manage a stack of patches using GIT as a backend"
arch="noarch"
@@ -11,15 +11,20 @@ license="GPL-2.0-or-later"
options="!check" # unit-tests fail due to iconv usage
depends="git python3"
makedepends="asciidoc xmlto perl"
-subpackages="$pkgname-doc"
-source="${pkgname}-${pkgver}.tar.gz::https://github.com/ctmarinas/stgit/archive/v${pkgver}.tar.gz"
+subpackages="
+ $pkgname-doc
+ $pkgname-zsh-completion:zshcomp:noarch
+ $pkgname-fish-completion:fishcomp:noarch
+ $pkgname-bash-completion:bashcomp:noarch
+ "
+source="$pkgname-$pkgver.tar.gz::https://github.com/ctmarinas/stgit/archive/v$pkgver.tar.gz"
prepare() {
default_prepare
# this will be a noop, as we are working with a tarball,
# but throws git errors --> just get rid of it
- echo "version=\"${pkgver}\"" > stgit/builtin_version.py
+ echo "version=\"$pkgver\"" > stgit/builtin_version.py
}
check() {
@@ -47,4 +52,37 @@ package() {
install install-doc
}
-sha512sums="6b4f184b91614961d759e8abd505856d74354e7d269d013a448e6795ecb35054277c319ee97f1df9bee3ed4861b70090133ed4f156c96908c2182ed4652304ba stgit-0.19.tar.gz"
+bashcomp() {
+ depends=""
+ pkgdesc="Bash completions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
+
+ mkdir -p "$subpkgdir"/usr/share/bash-completion/completions
+ mv "$pkgdir"/usr/share/stgit/completion/stgit.bash \
+ "$subpkgdir"/usr/share/bash-completion/completions/stgit
+ rmdir -p "$pkgdir"/usr/share/stgit/completion || true
+}
+
+zshcomp() {
+ depends=""
+ pkgdesc="Zsh compltions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel zsh"
+
+ mkdir -p "$subpkgdir"/usr/share/zsh/site-functions
+ mv "$pkgdir"/usr/share/stgit/completion/stgit.zsh \
+ "$subpkgdir"/usr/share/zsh/site-functions/_stgit
+ rmdir -p "$pkgdir"/usr/share/stgit/completions || true
+}
+
+fishcomp() {
+ depends=""
+ pkgdesc="Fish completions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel fish"
+
+ mkdir -p "$subpkgdir"/usr/share/fish/completions
+ mv "$pkgdir"/usr/share/stgit/completion/stg.fish \
+ "$subpkgdir"/usr/share/fish/completions/stg.fish
+ rmdir -p "$pkgdir"/usr/share/stgit/completions || true
+}
+
+sha512sums="0ea60462e1ac5c8329092b774b66caa98230ddc843f0302ceb42ce20e2f3c69b0e011801ebd61f523f7f6ca168bf9dbc5c617e38de4a93b68147a5d8094ba532 stgit-0.20.tar.gz"