aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorKeith Maxwell <keith.maxwell@gmail.com>2020-04-07 12:01:17 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-04-07 12:16:33 +0000
commitc28b0a666f1b893f44f0860f3d6f082028ac1a28 (patch)
tree8eda192a471beea628f731273aef48a5448a90b6 /testing
parent1fcc9f372dcd6341e788355856fdca2c9db670cb (diff)
downloadaports-c28b0a666f1b893f44f0860f3d6f082028ac1a28.tar.bz2
aports-c28b0a666f1b893f44f0860f3d6f082028ac1a28.tar.xz
testing/py3-grpcio: upgrade to 1.28.1
Disable on ppc64le to avoid an error: third_party/abseil-cpp/absl/base/internal/unscaledcycleclock.cc:100:2: error: #error Must implement UnscaledCycleClock::Frequency() linux-headers is now a dependency: https://github.com/grpc/grpc/issues/21918#issuecomment-582589140 abseil is a git submodule and therefore must be downloaded separately: https://github.com/grpc/grpc/issues/21956#issuecomment-584776736 See also community/grpc
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-grpcio/APKBUILD22
1 files changed, 17 insertions, 5 deletions
diff --git a/testing/py3-grpcio/APKBUILD b/testing/py3-grpcio/APKBUILD
index b986b1bff7..c40eb434c4 100644
--- a/testing/py3-grpcio/APKBUILD
+++ b/testing/py3-grpcio/APKBUILD
@@ -1,19 +1,30 @@
# Contributor: Keith Maxwell <keith.maxwell@gmail.com>
# Maintainer: Keith Maxwell <keith.maxwell@gmail.com>
pkgname=py3-grpcio
-pkgver=1.26.0
+pkgver=1.28.1
pkgrel=0
pkgdesc="gRPC Python HTTP/2-based RPC framework"
url="https://grpc.io"
-arch="all"
+arch="all !ppc64le" # no ppc64le -needs UnscaledCycleClock::Frequency()
license="Apache-2.0"
makedepends="python3-dev py3-setuptools py3-six cython zlib-dev openssl-dev
- c-ares-dev"
+ c-ares-dev linux-headers"
options="!check" # tests depend upon bazel
-source="grpc-$pkgver.tar.gz::https://github.com/grpc/grpc/archive/v$pkgver.tar.gz"
+_abseil_cpp_rev=b832dce8489ef7b6231384909fd9b68d5a5ff2b7
+source="grpc-$pkgver.tar.gz::https://github.com/grpc/grpc/archive/v$pkgver.tar.gz
+ abseil-cpp-$_abseil_cpp_rev.tar.gz::https://github.com/abseil/abseil-cpp/archive/$_abseil_cpp_rev.tar.gz
+ "
builddir="$srcdir/grpc-$pkgver"
+unpack() {
+ default_unpack
+
+ # the archive is missing git submodules
+ rmdir "$builddir/third_party/abseil-cpp"
+ ln -sn "$srcdir/abseil-cpp-$_abseil_cpp_rev/" "$builddir/third_party/abseil-cpp"
+}
+
_set_environment_variables() {
export GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY=1
export GRPC_PYTHON_BUILD_SYSTEM_CARES=1
@@ -32,4 +43,5 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="4f7d067c582d0a9be7b7d4dd1e08acdbe6ff0686dfe92b5db5b7927f779410a4237acfd1c61d9f79eb2d00f86cf93cc7492fa372c1877e57c1aa23e9bb2648bb grpc-1.26.0.tar.gz"
+sha512sums="5cc4993470e2df21447d032ddeb65ab4175bb8acad5a06fdd22564068b80a5be255ef0e44d36732642d39dc3eaec02a93d2aaf6e369ad5dc43ff99b5023f357b grpc-1.28.1.tar.gz
+1709f93c5f6bda7aefe7e8a19c86e93e00b3b06600f38ccb866c997221fe0bd44e903208cc1677ed3ec5e3efe9f69c550b03bb6b9edc307d9ccc38290bbae627 abseil-cpp-b832dce8489ef7b6231384909fd9b68d5a5ff2b7.tar.gz"