aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJean-Louis Fuchs <ganwell@fangorn.ch>2017-04-04 11:34:58 +0200
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-04-04 09:58:38 +0000
commitc3954f42dfad795d1be8777615ceab1336550508 (patch)
tree2d1b6aadae43a98df2b78930b4a3ef6026191cfd /testing
parent4a6a2f4a333ee45f16e5bca4cbce5dd135042ac2 (diff)
downloadaports-c3954f42dfad795d1be8777615ceab1336550508.tar.bz2
aports-c3954f42dfad795d1be8777615ceab1336550508.tar.xz
testing/libkeyfinder: upgrade to 2.2.1
Diffstat (limited to 'testing')
-rw-r--r--testing/libkeyfinder/APKBUILD12
-rw-r--r--testing/libkeyfinder/issue_22.patch63
2 files changed, 4 insertions, 71 deletions
diff --git a/testing/libkeyfinder/APKBUILD b/testing/libkeyfinder/APKBUILD
index b2973a160a..73e090036d 100644
--- a/testing/libkeyfinder/APKBUILD
+++ b/testing/libkeyfinder/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Jean-Louis Fuchs <ganwell@fangorn.ch>
# Maintainer: Jean-Louis Fuchs <ganwell@fangorn.ch>
pkgname=libkeyfinder
-pkgver=2.2
+pkgver=2.2.1
pkgrel=0
pkgdesc="Musical key detection for digital audio"
url="http://www.ibrahimshaath.co.uk/keyfinder/"
@@ -11,7 +11,6 @@ license="GPL"
makedepends="qt-dev fftw-dev"
subpackages="$pkgname-dev $pkgname-doc"
source="libkeyfinder-$pkgver.tar.gz::https://github.com/ibsh/libKeyFinder/archive/v$pkgver.tar.gz
- issue_22.patch
alpine-settings-to-pro.patch"
builddir="$srcdir/libKeyFinder-$pkgver"
@@ -39,12 +38,9 @@ check() {
LD_LIBRARY_PATH="$builddir" ./tests
}
-md5sums="c19eaf976afe10ba0cf15c0aba45618c libkeyfinder-2.2.tar.gz
-17d4692e8c39c0f607981058f531970d issue_22.patch
+md5sums="4d29fb42f1ec55766652eb3f8296d8a2 libkeyfinder-2.2.1.tar.gz
2650ed076d43872cc474099021bd84cd alpine-settings-to-pro.patch"
-sha256sums="cd9337899e0d71bb0fda2726630f72aaf6a05a3ec7b27df7e42fd27409a88c96 libkeyfinder-2.2.tar.gz
-2e570a3d682f365cac5d0c49aaa139cb559cb36ca37e26b7b9b05dccdb9f3a7f issue_22.patch
+sha256sums="f168247012da2467af846d5a1301ca3eff23eb48938fb9b2dbbfa8dd0e5ccf10 libkeyfinder-2.2.1.tar.gz
bc2dd2f8948d6565dd90b75074d7f2e61802d9e2f67e315ba92464958e5dc0ea alpine-settings-to-pro.patch"
-sha512sums="8e35473d34cb715d9eb383733ca07f659fd116f65a923fa3948d99dc4cfb04e43b4cf0bb411345574d42bb40fae8d818253f8cdbcbb5fb3aaab88bcc57f7b687 libkeyfinder-2.2.tar.gz
-a73e24f96708615b8d3073de8eac32a17be6947b3c99f94be57d09577278eedcf668849c75c20fe74a35bd74e8b41f92d08627c5f0fff3198cf60867262bcd6a issue_22.patch
+sha512sums="62790681e34e8513ac185396c9f76981238da3136a9bd646b197a1e7032d6d612e90157be9dd13700bbeb98085ee3d628ae847716e0091490cd6c3839bf2c25d libkeyfinder-2.2.1.tar.gz
580c968da0d24126d92b09cc4a970bb898fe020f2b9a9232d80ef63be8d3f90e618ea0b2f66ccde174a51dcf7160dfd62ab3b9428bf0ae6b11608b7dd7aede23 alpine-settings-to-pro.patch"
diff --git a/testing/libkeyfinder/issue_22.patch b/testing/libkeyfinder/issue_22.patch
deleted file mode 100644
index a21338ccf8..0000000000
--- a/testing/libkeyfinder/issue_22.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-commit 1be2a3290389b53e1e9f91710bcc6d1ccad2abe9
-Author: Jean-Louis Fuchs <ganwell@fangorn.ch>
-Date: Thu Mar 23 23:09:14 2017 +0100
-
- Alpine patch
-
-diff --git a/fftadapter.cpp b/fftadapter.cpp
-index 57e8197..1ec7c6c 100644
---- a/fftadapter.cpp
-+++ b/fftadapter.cpp
-@@ -40,6 +40,7 @@ namespace KeyFinder {
- frameSize = inFrameSize;
- priv->inputReal = (double*)fftw_malloc(sizeof(double) * frameSize);
- priv->outputComplex = (fftw_complex*)fftw_malloc(sizeof(fftw_complex) * frameSize);
-+ memset(priv->outputComplex, 0, sizeof(fftw_complex) * frameSize);
- fftwPlanMutex.lock();
- priv->plan = fftw_plan_dft_r2c_1d(frameSize, priv->inputReal, priv->outputComplex, FFTW_ESTIMATE);
- fftwPlanMutex.unlock();
-diff --git a/tests/audiodatatest.cpp b/tests/audiodatatest.cpp
-index 30657a7..a96e0ab 100644
---- a/tests/audiodatatest.cpp
-+++ b/tests/audiodatatest.cpp
-@@ -296,12 +296,12 @@ TEST_CASE ("AudioDataTest/DownsamplerResamplesNonintegralRelationship") {
- KeyFinder::AudioData a;
- a.setChannels(1);
- a.setFrameRate(100);
-- a.addToSampleCount(12);
-+ a.addToSampleCount(15);
- for (unsigned int i = 0; i < 5; i++)
- a.setSample(i, 100.0);
- for (unsigned int i = 5; i < 10; i++)
- a.setSample(i, 500.0);
-- for (unsigned int i = 10; i < 12; i++)
-+ for (unsigned int i = 10; i < 15; i++)
- a.setSample(i, 1000.0);
-
- a.downsample(5);
-@@ -309,7 +309,6 @@ TEST_CASE ("AudioDataTest/DownsamplerResamplesNonintegralRelationship") {
- ASSERT_EQ(3, a.getSampleCount());
- ASSERT_FLOAT_EQ(100.0, a.getSample(0));
- ASSERT_FLOAT_EQ(500.0, a.getSample(1));
-- // this doesn't make total mathematical sense but I'm taking a shortcut for performance
- ASSERT_FLOAT_EQ(1000.0, a.getSample(2));
- }
-
-diff --git a/tests/lowpassfiltertest.cpp b/tests/lowpassfiltertest.cpp
-index 6135ed0..21220ff 100644
---- a/tests/lowpassfiltertest.cpp
-+++ b/tests/lowpassfiltertest.cpp
-@@ -194,7 +194,6 @@ TEST (LowPassFilterTest, WorksOnRepetitiveWaves) {
- TEST (LowPassFilterTest, DefaultFilterMatchesFisherCoefficients) {
- KeyFinder::LowPassFilter* lpf = new KeyFinder::LowPassFilter(160, 44100, 2000.0, 2048);
- std::vector<double>* myCoeffs = (std::vector<double>*)lpf->getCoefficients();
-- delete lpf;
-
- float fisherCoeffsFirstHalf[] = {
- -0.0022979864, -0.0014851155, -0.0005276345, +0.0005287637,
-@@ -224,4 +223,5 @@ TEST (LowPassFilterTest, DefaultFilterMatchesFisherCoefficients) {
- ASSERT_FLOAT_EQ(fisherCoeffsFirstHalf[i], myCoeffs->at(i));
- ASSERT_FLOAT_EQ(myCoeffs->at(i), myCoeffs->at(160 - i));
- }
-+ delete lpf;
- }