aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-11-05 11:44:29 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-11-05 15:35:40 +0000
commitc5f8982a543127c6bf282d9846c498b1ef2c7752 (patch)
tree6c9025bb8ca0db24ecc1513ce51434c70515e390 /testing
parentedbd2f3a728b6059dee9b8755a134a05e61cdd6c (diff)
downloadaports-c5f8982a543127c6bf282d9846c498b1ef2c7752.tar.bz2
aports-c5f8982a543127c6bf282d9846c498b1ef2c7752.tar.xz
testing/mlt: rebuild against python 3.8
replace python3 patch with upstream patch
Diffstat (limited to 'testing')
-rw-r--r--testing/mlt/APKBUILD6
-rw-r--r--testing/mlt/python3.patch19
-rw-r--r--testing/mlt/switch-to-python3-by-default.patch118
3 files changed, 121 insertions, 22 deletions
diff --git a/testing/mlt/APKBUILD b/testing/mlt/APKBUILD
index c2eee86046..04b96293af 100644
--- a/testing/mlt/APKBUILD
+++ b/testing/mlt/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=mlt
pkgver=6.16.0
-pkgrel=2
+pkgrel=3
pkgdesc="MLT Multimedia Framework"
url="https://www.mltframework.org/"
arch="all"
@@ -13,7 +13,7 @@ makedepends="python3-dev ffmpeg-dev libsamplerate-dev sox-dev jack-dev
subpackages="$pkgname-dev py3-$pkgname:py3"
source="https://github.com/mltframework/mlt/releases/download/v$pkgver/mlt-$pkgver.tar.gz
musl-locale.patch
- python3.patch
+ switch-to-python3-by-default.patch
"
build() {
@@ -52,4 +52,4 @@ py3() {
sha512sums="554e8b9baa7a8578cc52315fe0583c61762bf6fbbcdd4a1e4f25753846d92f013e7d74745498625fcc781de993aa0526fd761920450b4314e67105783b9bde26 mlt-6.16.0.tar.gz
dfa4c192ce6121a3c86141c46a08eaf6cd6bd81c120786bdb1ef564bf7878dcb44031280b34609048409c3d09e8c0e1bd430dae1fe777ef030daf09b1dfd90a3 musl-locale.patch
-f354662b818d7e8f75e69cb48ae4bb79ff4e708d845736aed1ce70f025941f36b605dfe04831e68c7256bb6edf6fe163a69d47793810458748780387cafe2316 python3.patch"
+0253cf7aeca4a1a2e8148fccd6341f2be5d4f77663f0a83a00073c698c8507adcbfeedc7ac9b9fc2af35d14841ccf8167dc996591f910919a4fb017f0044cc4a switch-to-python3-by-default.patch"
diff --git a/testing/mlt/python3.patch b/testing/mlt/python3.patch
deleted file mode 100644
index ac32c9011d..0000000000
--- a/testing/mlt/python3.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff --git a/src/swig/python/build b/src/swig/python/build
-index db31e16..4eb69e2 100755
---- a/src/swig/python/build
-+++ b/src/swig/python/build
-@@ -8,12 +8,12 @@ then
- exit 0
- fi
-
--path=`which python 2> /dev/null`
-+path=`which python3 2> /dev/null`
-
- if [ $? = 0 ]
- then
- # Change this as needed
-- export PYTHON_INCLUDE=`python -c "import sys;print(\"{}/include/python{}.{}\".format(sys.prefix,*sys.version_info))"`
-+ export PYTHON_INCLUDE=`python3 -c "import sys;print(\"{}/include/python{}.{}m\".format(sys.prefix,*sys.version_info))"`
-
- [ ! -d "$PYTHON_INCLUDE" ] && echo python development missing && exit 1
-
diff --git a/testing/mlt/switch-to-python3-by-default.patch b/testing/mlt/switch-to-python3-by-default.patch
new file mode 100644
index 0000000000..b36508ce2f
--- /dev/null
+++ b/testing/mlt/switch-to-python3-by-default.patch
@@ -0,0 +1,118 @@
+From 12d4f46a957ab4eba155940b44bb31c35697da26 Mon Sep 17 00:00:00 2001
+From: Dan Dennedy <dan@dennedy.org>
+Date: Sat, 21 Sep 2019 18:29:51 -0700
+Subject: [PATCH] switch to python3 by default
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+patch by Patrick Matthäi
+---
+ src/swig/python/build | 6 +++---
+ src/swig/python/codecs.py | 2 +-
+ src/swig/python/getimage.py | 2 +-
+ src/swig/python/play.py | 2 +-
+ src/swig/python/switcher.py | 2 +-
+ src/swig/python/test_animation.py | 2 +-
+ src/swig/python/waveforms.py | 2 +-
+ src/swig/python/webvfx_generator.py | 2 +-
+ 8 files changed, 10 insertions(+), 10 deletions(-)
+
+diff --git a/src/swig/python/build b/src/swig/python/build
+index db31e164d..c783dd295 100755
+--- a/src/swig/python/build
++++ b/src/swig/python/build
+@@ -8,12 +8,12 @@ then
+ exit 0
+ fi
+
+-path=`which python 2> /dev/null`
++path=`which python3 2> /dev/null`
+
+ if [ $? = 0 ]
+ then
+ # Change this as needed
+- export PYTHON_INCLUDE=`python -c "import sys;print(\"{}/include/python{}.{}\".format(sys.prefix,*sys.version_info))"`
++ export PYTHON_INCLUDE=`python3 -c "import sys;print(\"{}/include/python{}.{}\".format(sys.prefix,*sys.version_info))"`
+
+ [ ! -d "$PYTHON_INCLUDE" ] && echo python development missing && exit 1
+
+@@ -26,7 +26,7 @@ then
+ ${CXX} -fPIC -D_GNU_SOURCE ${CXXFLAGS} -c -I../.. -I$PYTHON_INCLUDE mlt_wrap.cxx || exit $?
+
+ # Create the module
+- ${CXX} ${CXXFLAGS} -shared mlt_wrap.o -L../../mlt++ -lmlt++ -L../../framework -lmlt $(python-config --ldflags) -o _mlt.so || exit $?
++ ${CXX} ${CXXFLAGS} -shared mlt_wrap.o -L../../mlt++ -lmlt++ -L../../framework -lmlt $(python3-config --ldflags) -o _mlt.so || exit $?
+ else
+ echo Python not installed.
+ exit 1
+diff --git a/src/swig/python/codecs.py b/src/swig/python/codecs.py
+index 64f2815f9..03be93458 100755
+--- a/src/swig/python/codecs.py
++++ b/src/swig/python/codecs.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ # -*- coding: utf-8 -*-
+
+ # Import required modules
+diff --git a/src/swig/python/getimage.py b/src/swig/python/getimage.py
+index 51e042da6..abe7a9db5 100755
+--- a/src/swig/python/getimage.py
++++ b/src/swig/python/getimage.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ # -*- coding: utf-8 -*-
+ import mlt
+ import sys
+diff --git a/src/swig/python/play.py b/src/swig/python/play.py
+index 13c34b160..69ef42e6a 100755
+--- a/src/swig/python/play.py
++++ b/src/swig/python/play.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ # -*- coding: utf-8 -*-
+
+ # Import required modules
+diff --git a/src/swig/python/switcher.py b/src/swig/python/switcher.py
+index d0994a561..e843e84fa 100755
+--- a/src/swig/python/switcher.py
++++ b/src/swig/python/switcher.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ # -*- coding: utf-8 -*-
+
+ # Import required modules
+diff --git a/src/swig/python/test_animation.py b/src/swig/python/test_animation.py
+index ef484abf7..c2960a7b9 100755
+--- a/src/swig/python/test_animation.py
++++ b/src/swig/python/test_animation.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ # -*- coding: utf-8 -*-
+
+ from __future__ import print_function
+diff --git a/src/swig/python/waveforms.py b/src/swig/python/waveforms.py
+index e39d0f27e..3f712ee84 100755
+--- a/src/swig/python/waveforms.py
++++ b/src/swig/python/waveforms.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ # -*- coding: utf-8 -*-
+ import mlt
+ from PIL import Image
+diff --git a/src/swig/python/webvfx_generator.py b/src/swig/python/webvfx_generator.py
+index 26cb196a2..4b723356e 100755
+--- a/src/swig/python/webvfx_generator.py
++++ b/src/swig/python/webvfx_generator.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ # -*- coding: utf-8 -*-
+
+ # webvfx_generator.py