aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBrad Fritz <brad@fewerhassles.com>2018-11-30 18:02:16 -0500
committerSören Tempel <soeren+git@soeren-tempel.net>2018-12-14 11:15:40 +0100
commitc5fe2726909ed3f2d7aefedbc3532d039d2a2232 (patch)
treebe7bc66798956521abdea377842f60ea562d574b /testing
parenta7868eb5acbd3b61fad088fbf4440d1eca1ba3d8 (diff)
downloadaports-c5fe2726909ed3f2d7aefedbc3532d039d2a2232.tar.bz2
aports-c5fe2726909ed3f2d7aefedbc3532d039d2a2232.tar.xz
testing/openocd: enable bcm2835gpio for Raspberry Pi
Follow-up to 958a8ae7e7 because the 0.10.0 [release notes] also request `--enable-bcm2835gpio` for builds that support Raspberry Pi: > 7. Please add --enable-sysfsgpio for all targets running Linux, the > kernel (esp. useful for SBCs), additionally for builds that support > RaspberryPi, please add --enable-bcm2835gpio `--enable-bcm2835gpio` is ignored when building on non-ARM architectures. This configuration is also consistent with the [Debian packaging]. [release notes]: https://sourceforge.net/p/openocd/mailman/message/35570895/ [Debian packaging]: https://salsa.debian.org/electronics-team/openocd/blob/debian/0.10.0-4/debian/rules#L33
Diffstat (limited to 'testing')
-rw-r--r--testing/openocd/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/testing/openocd/APKBUILD b/testing/openocd/APKBUILD
index 455f037199..3042b8b735 100644
--- a/testing/openocd/APKBUILD
+++ b/testing/openocd/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=openocd
pkgver=0.10.0
-pkgrel=3
+pkgrel=4
pkgdesc="Free and Open On-Chip Debugging, In-System Programming and Boundary-Scan Testing"
url="http://openocd.org/"
arch="all"
@@ -26,7 +26,8 @@ build() {
--localstatedir=/var \
--disable-werror \
--enable-cmsis-dap \
- --enable-sysfsgpio
+ --enable-sysfsgpio \
+ --enable-bcm2835gpio
make
}