aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2020-05-02 22:16:35 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2020-05-02 22:16:35 +0000
commitcf05c2d05918e7af2cc49a0cb507b0613e5e2b36 (patch)
tree2a51e2ede5439c74e8d088d43bb0557f89eea4ec /testing
parent7bc5446db92045d221cce111232838068d3dd5e9 (diff)
downloadaports-cf05c2d05918e7af2cc49a0cb507b0613e5e2b36.tar.bz2
aports-cf05c2d05918e7af2cc49a0cb507b0613e5e2b36.tar.xz
testing/openscap: include limits.h for ppc64le
Diffstat (limited to 'testing')
-rw-r--r--testing/openscap/APKBUILD2
-rw-r--r--testing/openscap/fix-ppc64le-path_max.patch12
2 files changed, 13 insertions, 1 deletions
diff --git a/testing/openscap/APKBUILD b/testing/openscap/APKBUILD
index 895f0ab8fa..6dbf6c8393 100644
--- a/testing/openscap/APKBUILD
+++ b/testing/openscap/APKBUILD
@@ -52,5 +52,5 @@ bashcomp() {
}
sha512sums="e230668cdf900a2f31ccabc20787dce6c4174740aa7d2cc7b91c1c095e2a5b73d81bb614aa767d2e51383b5472def360c4204e9a6c4c85110c58b9999566613e openscap-1.3.3.tar.gz
-cd39ed6fa2f50620cad2881497ddc8b012b4641f90799324fdcb9ad8e6901d4065f03be607d858e48466fb5a0ba61815be66f93359763200c33a44b4d2e99ad7 fix-ppc64le-path_max.patch
+0d8e5eb492b4439b82e35e4a87a2030f9aeff3173bda60d8ce57584fa7d7dda970ad35099e45fe46a7e135d9a55d6c2ced0a8b180556e37c7a9926de28244133 fix-ppc64le-path_max.patch
f2157d6b1d31affe16edb184a287b69d28808123f1cc26a5a4238040d935517b307772b1f2d66271b8ee99b59a4d204930f9147b78478c83c36c7fc8718ec1d9 path_mounted.patch"
diff --git a/testing/openscap/fix-ppc64le-path_max.patch b/testing/openscap/fix-ppc64le-path_max.patch
index 1810966f06..5fd2981d87 100644
--- a/testing/openscap/fix-ppc64le-path_max.patch
+++ b/testing/openscap/fix-ppc64le-path_max.patch
@@ -20,3 +20,15 @@ index 95ef0a7..3ab2cb0 100644
#ifdef HAVE_PROC_DEVNAME_H
#include <proc/devname.h>
+diff --git a/src/OVAL/probes/independent/environmentvariable58_probe.c b/src/OVAL/probes/independent/environmentvariable58_probe.c
+index 552ce67..e2490ac 100644
+--- a/src/OVAL/probes/independent/environmentvariable58_probe.c
++++ b/src/OVAL/probes/independent/environmentvariable58_probe.c
+@@ -50,6 +50,7 @@
+ #include <fcntl.h>
+ #include <sys/types.h>
+ #include <dirent.h>
++#include <limits.h>
+
+ #include <probe/probe.h>
+ #include "_seap.h"