aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
author7heo <7heo@mail.com>2016-07-06 21:53:52 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-07-29 12:00:37 +0200
commitcf05f546a8c061d660eca00bf782253731a73de8 (patch)
tree1ba5fad0be468d12339f6fdd27bb6f0aef90246b /testing
parentac2ca35e4426fcb0458cf26c424f9e5f66219fe5 (diff)
downloadaports-cf05f546a8c061d660eca00bf782253731a73de8.tar.bz2
aports-cf05f546a8c061d660eca00bf782253731a73de8.tar.xz
testing/gogs: New version 0.9.48
Diffstat (limited to 'testing')
-rw-r--r--testing/gogs/APKBUILD69
-rw-r--r--testing/gogs/glide.lock274
-rw-r--r--testing/gogs/glide.yaml57
3 files changed, 360 insertions, 40 deletions
diff --git a/testing/gogs/APKBUILD b/testing/gogs/APKBUILD
index f2869df90c..3ba51bf9e4 100644
--- a/testing/gogs/APKBUILD
+++ b/testing/gogs/APKBUILD
@@ -1,50 +1,33 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: 7heo <7heo@mail.com>
pkgname=gogs
-pkgver=0.9.13
-pkgrel=1
+pkgver=0.9.48
+pkgrel=0
pkgdesc="A self-hosted Git service written in Go"
url="http://gogs.io/"
arch="all"
license="MIT"
depends="git"
-makedepends="go-tools perl libcap"
+makedepends="glide go-tools perl libcap"
install="$pkgname.pre-install"
pkgusers="gogs"
pkggroups="www-data"
options="!strip"
-source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.gz
+source="${pkgname}-${pkgver}.tar.gz::https://github.com/gogits/$pkgname/archive/v$pkgver.tar.gz
$pkgname.initd
$pkgname.confd
- $pkgname.ini"
-builddir="$srcdir/src/github.com/gogits"
-
-_disturl="dev.alpinelinux.org:/archive/$pkgname/"
-_gourl="github.com/gogits/gogs"
-
-snapshot() {
- abuild clean && abuild deps
- export GOPATH="$srcdir"
- msg "Checking out v${pkgver} tag"
- # go get will not checkout a specific tag
- # so we run our own git checkout branch
- git clone --quiet --branch v${pkgver} \
- https://$_gourl $builddir || return 1
- cd $builddir
- # fetch deps
- go get -v -d -tags "sqlite redis memcache" || return 1
- cd "$srcdir"
- tar zcf $pkgname-$pkgver.tar.gz src || return 1
- rsync --progress -La $pkgname-$pkgver.tar.gz \
- $_disturl || return 1
- cd $startdir && abuild undeps
-}
+ $pkgname.ini
+ glide.yaml
+ glide.lock"
+builddir="$srcdir/${pkgname}-${pkgver}"
build() {
- cd "$builddir"/$pkgname || return 1
- export GOPATH="$srcdir"
+ export GOPATH="$startdir"
+ cd "$builddir" || return 1
+ cp "$startdir/glide.yaml" "$startdir/glide.lock" .
+ glide install || return 1
go fix || return 1
- go build -buildmode=pie -v -tags "sqlite redis memcache cert" || return 1
+ go build -buildmode=pie -v -tags "sqlite redis memcache cert" || return 1 # sqlite causes problems without the pie buildmode
}
package() {
@@ -59,32 +42,38 @@ package() {
chown -R gogs:www-data "$pkgdir"/var/lib/$pkgname \
"$pkgdir"/var/cache/gogs/sessions \
"$pkgdir"/var/log/$pkgname || return 1
- install -Dm 0755 $pkgname/$pkgname \
+ install -D -m 0755 ${pkgname}-${pkgver} \
"$pkgdir"/usr/bin/$pkgname || return 1
# allow to bind to port 80
setcap cap_net_bind_service=+ep \
"$pkgdir"/usr/bin/$pkgname || return 1
install -d -o gogs -g www-data \
"$pkgdir"/etc/$pkgname/conf || return 1
- install -Dm 0664 -o gogs -g www-data "$srcdir"/${pkgname}.ini \
+ install -D -m 0664 -o gogs -g www-data "$srcdir"/${pkgname}.ini \
"$pkgdir"/etc/$pkgname/conf/app.ini || return 1
- mv $pkgname/public "$pkgdir"/usr/share/webapps/$pkgname/ || return 1
- mv $pkgname/templates "$pkgdir"/usr/share/webapps/$pkgname/ || return 1
+ mv public "$pkgdir"/usr/share/webapps/$pkgname/ || return 1
+ mv templates "$pkgdir"/usr/share/webapps/$pkgname/ || return 1
install -D -m755 "$srcdir"/$pkgname.initd \
"$pkgdir"/etc/init.d/$pkgname || return 1
install -D -m644 "$srcdir"/$pkgname.confd \
"$pkgdir"/etc/conf.d/$pkgname || return 1
}
-md5sums="0d609a490ea2b225cfc9153b47d7392a gogs-0.9.13.tar.gz
+md5sums="466d4b1a6a0575875b48f331bb87864f gogs-0.9.48.tar.gz
91cd8b6b27509beecb53594463315f43 gogs.initd
6b3f501f9c37b5032cab8b49b5621fc4 gogs.confd
-82edfdabfdf0ac64dc545036ca499465 gogs.ini"
-sha256sums="6c2f79eecfd89197ad6359f389e9de39cd4f7211566ef6488437e7f5dc94b31d gogs-0.9.13.tar.gz
+82edfdabfdf0ac64dc545036ca499465 gogs.ini
+c6ca5fa76a19e67b04a5785437594677 glide.yaml
+cf41ad11bb81bfed3e77268ef0bee322 glide.lock"
+sha256sums="b612b8994838ead81cd0d99da80ac32ed77b71d22af753c8c47a48db61b8eff7 gogs-0.9.48.tar.gz
23a9bfcf7d1fd7cb5b7bf13ab0b0f412c29c1ebdd62fc02c78dd885cbe5d703d gogs.initd
a1c584dbc2d44694ffcf87ecafdf6a43ae81370175ca9cc6e6ff7623b8b05254 gogs.confd
-ead0082c56e8e8f9e9ba7f4c206c2a18bb732726137b71e05d83347638562530 gogs.ini"
-sha512sums="88a6889ada2e42cc5b6e362a868230f3ce9f814cc6914cfe59abd5a320b0cb908e20d7f274c2f61f17b9a6d5e385633ffeb9697274ea5406fad3c0522dab9b49 gogs-0.9.13.tar.gz
+ead0082c56e8e8f9e9ba7f4c206c2a18bb732726137b71e05d83347638562530 gogs.ini
+a6f2c385236ad2fa27b682b209abc9605270066e948d2082f50cf3a2d366863e glide.yaml
+eedcf6b32e0da77491ef7fcf6cfd4eaa9390183838a54031c19c33d82e7c54da glide.lock"
+sha512sums="615e35b68b29d306a11874beae11e93973522970131516f67aabc90834db4297b4c2d386f1546a6d9c0e874cc77a5b3341732d701843456a47960c1e05a53ec7 gogs-0.9.48.tar.gz
be5a9ef2cae1ee2e8106feb6a997ae06519af91fe57f746d20996e79c332c93bb43fc53f79ff4e8ce13222afc6f3dc7bc5cbb758ef201b03e49d809c87c8c4c7 gogs.initd
52ce41c05c263b790221a04d13d2eb9bba689e4bd72daf5b6af31416e80a485a46bae19e18581d7bde879307283847e6486686a2fe4140fe38ebb6f315e11a86 gogs.confd
-4c2b398cf93ebb8b743b9e7ec1b075706427081036effb53fa90729e70fbc3eb92f2f853278b887ca79dc35cd55a64e1bff4d18e1ad246beab2a723aa9cd71ba gogs.ini"
+4c2b398cf93ebb8b743b9e7ec1b075706427081036effb53fa90729e70fbc3eb92f2f853278b887ca79dc35cd55a64e1bff4d18e1ad246beab2a723aa9cd71ba gogs.ini
+ed9753c8171b815f026fe4fa0cce01cc16328940c305559c6f92b5fb452fe423a8763138ef47ab7362cb5bab53209c7b1fa9644e148e7d5cae368ca729aba06a glide.yaml
+ba53a0eda53f297a898a684e91625cf9efd425ff78d10acd24027389dab3f74874b38d83c37a06cf9446d27312f64d58780f26140bdce16f72f7a8e7e77a5fdc glide.lock"
diff --git a/testing/gogs/glide.lock b/testing/gogs/glide.lock
new file mode 100644
index 0000000000..ab3605abca
--- /dev/null
+++ b/testing/gogs/glide.lock
@@ -0,0 +1,274 @@
+hash: a6f2c385236ad2fa27b682b209abc9605270066e948d2082f50cf3a2d366863e
+updated: 2016-07-28T10:53:31.795331716+02:00
+imports:
+- name: github.com/bradfitz/gomemcache
+ version: fb1f79c6b65acda83063cbc69f6bba1522558bfc
+ subpackages:
+ - memcache
+- name: github.com/codegangsta/cli
+ version: d9021faab69f92295ef7061bd39e4a76dcbdef32
+- name: github.com/go-macaron/binding
+ version: 9440f336b443056c90d7d448a0a55ad8c7599880
+- name: github.com/go-macaron/cache
+ version: 56173531277692bc2925924d51fda1cd0a6b8178
+ subpackages:
+ - memcache
+ - redis
+- name: github.com/go-macaron/captcha
+ version: 8aa5919789ab301e865595eb4b1114d6b9847deb
+- name: github.com/go-macaron/csrf
+ version: 6a9a7df172cc1fcd81e4585f44b09200b6087cc0
+- name: github.com/go-macaron/gzip
+ version: cad1c6580a07c56f5f6bc52d66002a05985c5854
+- name: github.com/go-macaron/i18n
+ version: ef57533c3b0fc2d8581deda14937e52f11a203ab
+- name: github.com/go-macaron/inject
+ version: d8a0b8677191f4380287cfebd08e462217bac7ad
+- name: github.com/go-macaron/session
+ version: 66031fcb37a0fff002a1f028eb0b3a815c78306b
+ subpackages:
+ - redis
+- name: github.com/go-macaron/toolbox
+ version: 99a42f20e9e88daec5c0d7beb4e7eac134680ab0
+- name: github.com/go-sql-driver/mysql
+ version: 3654d25ec346ee8ce71a68431025458d52a38ac0
+- name: github.com/go-xorm/core
+ version: bc1b7f81f0e369289078424064634a5ee7d21051
+- name: github.com/go-xorm/tidb
+ version: 79b229268e4e0bb287819c1e9ee9e5a75a7d473d
+- name: github.com/go-xorm/xorm
+ version: dddc985b860d64f7b6370afd65a8316425e13181
+- name: github.com/gogits/chardet
+ version: 2404f777256163ea3eadb273dada5dcb037993c0
+- name: github.com/gogits/cron
+ version: 96040e4fab17baa0391ce571694e4ccb5fce5dac
+- name: github.com/gogits/git-module
+ version: 53bcb7352ff838610c537c9b589ca79bca92c661
+- name: github.com/gogits/go-gogs-client
+ version: 442b4e5ddc8029932c91872f8322fb7a2c2de858
+- name: github.com/gogits/gogs
+ version: ad7ea88923e371df7558835d8f3e0236cfdf69ba
+ subpackages:
+ - cmd
+ - modules/setting
+ - models
+ - modules/auth
+ - modules/base
+ - modules/bindata
+ - modules/context
+ - modules/httplib
+ - modules/log
+ - modules/template
+ - routers
+ - routers/admin
+ - routers/api/v1
+ - routers/dev
+ - routers/org
+ - routers/repo
+ - routers/user
+ - models/migrations
+ - modules/auth/ldap
+ - modules/auth/pam
+ - modules/avatar
+ - modules/mailer
+ - modules/markdown
+ - modules/process
+ - modules/template/highlight
+ - modules/user
+ - modules/cron
+ - modules/ssh
+ - routers/api/v1/admin
+ - routers/api/v1/misc
+ - routers/api/v1/org
+ - routers/api/v1/repo
+ - routers/api/v1/user
+ - routers/api/v1/convert
+- name: github.com/golang/protobuf
+ version: c3cefd437628a0b7d31b34fe44b3a7a540e98527
+ subpackages:
+ - proto
+- name: github.com/golang/snappy
+ version: d9eb7a3d35ec988b8585d4a0068e462c27d28380
+- name: github.com/issue9/identicon
+ version: d36b54562f4cf70c83653e13dc95c220c79ef521
+- name: github.com/jaytaylor/html2text
+ version: 52d9b785554a1918cb09909b89a1509a98b853fd
+- name: github.com/juju/errors
+ version: b2c7a7da5b2995941048f60146e67702a292e468
+- name: github.com/kardianos/minwinsvc
+ version: cad6b2b879b0970e4245a20ebf1a81a756e2bb70
+- name: github.com/klauspost/compress
+ version: 14eb9c4951195779ecfbec34431a976de7335b0a
+ subpackages:
+ - gzip
+ - flate
+- name: github.com/klauspost/cpuid
+ version: 09cded8978dc9e80714c4d85b0322337b0a1e5e0
+- name: github.com/klauspost/crc32
+ version: 19b0b332c9e4516a6370a0456e6182c3b5036720
+- name: github.com/lib/pq
+ version: 4dd446efc17690bc53e154025146f73203b18309
+ subpackages:
+ - oid
+- name: github.com/mattn/go-sqlite3
+ version: e118d4451349065b8e7ce0f0af32e033995363f8
+- name: github.com/mcuadros/go-version
+ version: d52711f8d6bea8dc01efafdb68ad95a4e2606630
+- name: github.com/microcosm-cc/bluemonday
+ version: 9dc199233bf72cc1aad9b61f73daf2f0075b9ee4
+- name: github.com/msteinert/pam
+ version: 02ccfbfaf0cc627aa3aec8ef7ed5cfeec5b43f63
+- name: github.com/nfnt/resize
+ version: 891127d8d1b52734debe1b3c3d7e747502b6c366
+- name: github.com/ngaut/log
+ version: 37d3e0f43b4fe05429e1adb75e835bf31fc1bba6
+- name: github.com/petar/GoLLRB
+ version: 53be0d36a84c2a886ca057d34b6aa4468df9ccb4
+ subpackages:
+ - llrb
+- name: github.com/pingcap/goleveldb
+ version: c131135d59a38f4212f627cde570dddfe5261c43
+ subpackages:
+ - leveldb
+ - leveldb/comparer
+ - leveldb/iterator
+ - leveldb/memdb
+ - leveldb/util
+ - leveldb/opt
+ - leveldb/storage
+ - leveldb/cache
+ - leveldb/errors
+ - leveldb/filter
+ - leveldb/journal
+ - leveldb/table
+- name: github.com/pingcap/tidb
+ version: 60d0c97721987d7c5acece0d34791559acb26f9a
+ subpackages:
+ - ast
+ - context
+ - domain
+ - executor
+ - infoschema
+ - kv
+ - meta
+ - metric
+ - model
+ - mysql
+ - parser
+ - perfschema
+ - privilege
+ - privilege/privileges
+ - sessionctx
+ - sessionctx/autocommit
+ - sessionctx/db
+ - sessionctx/forupdate
+ - sessionctx/variable
+ - store/localstore
+ - store/localstore/engine
+ - store/localstore/goleveldb
+ - terror
+ - util
+ - util/types
+ - parser/opcode
+ - util/distinct
+ - ddl
+ - evaluator
+ - expression
+ - inspectkv
+ - plan
+ - plan/statistics
+ - table
+ - util/charset
+ - util/codec
+ - util/sqlexec
+ - xapi
+ - meta/autoid
+ - table/tables
+ - structure
+ - tablecodec
+ - util/bytes
+ - util/segmentmap
+ - xapi/xeval
+ - util/hack
+ - util/stringutil
+- name: github.com/pingcap/tipb
+ version: dd28a39ad25a0fb293ffdfc8548bf926a90fe70e
+ subpackages:
+ - go-tipb
+- name: github.com/rcrowley/go-metrics
+ version: bdb33529eca3e55eac7328e07c57012a797af602
+- name: github.com/russross/blackfriday
+ version: 93622da34e54fb6529bfb7c57e710f37a8d9cbd8
+- name: github.com/satori/go.uuid
+ version: 0aa62d5ddceb50dbcb909d790b5345affd3669b6
+- name: github.com/sergi/go-diff
+ version: ec7fdbb58eb3e300c8595ad5ac74a5aa50019cc7
+ subpackages:
+ - diffmatchpatch
+- name: github.com/shurcooL/sanitized_anchor_name
+ version: 10ef21a441db47d8b13ebcc5fd2310f636973c77
+- name: github.com/twinj/uuid
+ version: b505f2cca343b7b21416b27b1f2ad88469800892
+- name: github.com/Unknwon/cae
+ version: c6aac99ea2cae2ebaf23f26f76b04fe3fcfc9f8c
+ subpackages:
+ - zip
+- name: github.com/Unknwon/com
+ version: 28b053d5a2923b87ce8c5a08f3af779894a72758
+- name: github.com/Unknwon/i18n
+ version: 39d6f2727e0698b1021ceb6a77c1801aa92e7d5d
+- name: github.com/Unknwon/paginater
+ version: 7748a72e01415173a27d79866b984328e7b0c12b
+- name: golang.org/x/crypto
+ version: bc89c496413265e715159bdc8478ee9a92fdc265
+ subpackages:
+ - ssh
+ - curve25519
+ - ed25519
+ - ed25519/internal/edwards25519
+- name: golang.org/x/net
+ version: 6a513affb38dc9788b449d59ffed099b8de18fa0
+ subpackages:
+ - html
+ - html/charset
+ - html/atom
+- name: golang.org/x/sys
+ version: a646d33e2ee3172a661fc09bca23bb4889a41bc8
+ subpackages:
+ - windows/svc
+ - windows
+- name: golang.org/x/text
+ version: 2910a502d2bf9e43193af9d68ca516529614eed3
+ subpackages:
+ - transform
+ - language
+ - encoding
+ - encoding/charmap
+ - encoding/htmlindex
+ - internal/tag
+ - encoding/internal/identifier
+ - encoding/internal
+ - encoding/japanese
+ - encoding/korean
+ - encoding/simplifiedchinese
+ - encoding/traditionalchinese
+ - encoding/unicode
+ - internal/utf8internal
+ - runes
+- name: gopkg.in/alexcesaro/quotedprintable.v3
+ version: 2caba252f4dc53eaf6b553000885530023f54623
+- name: gopkg.in/asn1-ber.v1
+ version: 4e86f4367175e39f69d9358a5f17b4dda270378d
+- name: gopkg.in/bufio.v1
+ version: 567b2bfa514e796916c4747494d6ff5132a1dfce
+- name: gopkg.in/gomail.v2
+ version: 81ebce5c23dfd25c6c67194b37d3dd3f338c98b1
+- name: gopkg.in/ini.v1
+ version: cf53f9204df4fbdd7ec4164b57fa6184ba168292
+- name: gopkg.in/ldap.v2
+ version: 537128fee7cca108d8ce74e4309fdfcdd9c7f496
+- name: gopkg.in/macaron.v1
+ version: 2133042f8d1022b8253e4e23f7940467941409ce
+- name: gopkg.in/redis.v2
+ version: e6179049628164864e6e84e973cfb56335748dea
+devImports: []
diff --git a/testing/gogs/glide.yaml b/testing/gogs/glide.yaml
new file mode 100644
index 0000000000..a61d1052ef
--- /dev/null
+++ b/testing/gogs/glide.yaml
@@ -0,0 +1,57 @@
+package: gogs-0.9.48
+import:
+- package: github.com/Unknwon/cae
+ subpackages:
+ - zip
+- package: github.com/Unknwon/com
+- package: github.com/Unknwon/i18n
+- package: github.com/Unknwon/paginater
+- package: github.com/codegangsta/cli
+- package: github.com/go-macaron/binding
+- package: github.com/go-macaron/cache
+ subpackages:
+ - memcache
+ - redis
+- package: github.com/go-macaron/captcha
+- package: github.com/go-macaron/csrf
+- package: github.com/go-macaron/gzip
+- package: github.com/go-macaron/i18n
+- package: github.com/go-macaron/session
+ subpackages:
+ - redis
+- package: github.com/go-macaron/toolbox
+- package: github.com/go-sql-driver/mysql
+- package: github.com/go-xorm/core
+- package: github.com/go-xorm/xorm
+- package: github.com/gogits/chardet
+- package: github.com/gogits/cron
+- package: github.com/gogits/git-module
+- package: github.com/gogits/go-gogs-client
+- package: github.com/issue9/identicon
+- package: github.com/kardianos/minwinsvc
+- package: github.com/lib/pq
+- package: github.com/mattn/go-sqlite3
+- package: github.com/mcuadros/go-version
+- package: github.com/microcosm-cc/bluemonday
+- package: github.com/msteinert/pam
+- package: github.com/nfnt/resize
+- package: github.com/russross/blackfriday
+- package: github.com/satori/go.uuid
+- package: github.com/sergi/go-diff
+ subpackages:
+ - diffmatchpatch
+- package: golang.org/x/crypto
+ subpackages:
+ - ssh
+- package: golang.org/x/net
+ subpackages:
+ - html
+ - html/charset
+- package: golang.org/x/text
+ subpackages:
+ - transform
+ - language
+- package: gopkg.in/gomail.v2
+- package: gopkg.in/ini.v1
+- package: gopkg.in/ldap.v2
+- package: gopkg.in/macaron.v1