aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2019-04-03 00:28:23 +0200
committerprspkt <prspkt@protonmail.com>2019-04-04 22:14:46 +0300
commitcf979987853f9318996f7884b05f8d98384badd7 (patch)
tree4c6106d5f414afe812a12df5a3bcf32500b395ba /testing
parentc2c06aa456a8c538e33d1588e979e73ef8d63126 (diff)
downloadaports-cf979987853f9318996f7884b05f8d98384badd7.tar.bz2
aports-cf979987853f9318996f7884b05f8d98384badd7.tar.xz
testing/multirun: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/multirun/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/multirun/APKBUILD b/testing/multirun/APKBUILD
new file mode 100644
index 0000000000..6501e21c85
--- /dev/null
+++ b/testing/multirun/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: TBK <alpine@jjtc.eu>
+# Maintainer: TBK <alpine@jjtc.eu>
+pkgname=multirun
+pkgver=0.3.1
+pkgrel=0
+pkgdesc="A minimalist init process designed for Docker."
+url="https://nicolas-van.github.io/multirun/"
+arch="all"
+license="MIT"
+checkdepends="bats"
+source="$pkgname-$pkgver.tar.gz::https://github.com/nicolas-van/multirun/archive/$pkgver.tar.gz"
+
+build() {
+ make
+}
+
+check() {
+ bats tests.bats
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="0a55470077b2bc2559e94f608f9ed53194512b5eca14eb62fffacd52123fa5335e28b85333c24039881f43fd56ac8f06ece0a13c495898faee830e8674b380ad multirun-0.3.1.tar.gz"