aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2018-08-05 13:37:28 -0400
committerNatanael Copa <ncopa@alpinelinux.org>2018-09-04 08:44:49 +0000
commitd04fc0551207817dd9a1b333759766cdf4034d2b (patch)
treed1071919b76689c9838e281e94a6db47817c454a /testing
parent8496a90c77db3ee7edfc9262b7382c6d9925d826 (diff)
downloadaports-d04fc0551207817dd9a1b333759766cdf4034d2b.tar.bz2
aports-d04fc0551207817dd9a1b333759766cdf4034d2b.tar.xz
testing/py-pypeg2: fix python 3 package
Diffstat (limited to 'testing')
-rw-r--r--testing/py-pypeg2/APKBUILD40
1 files changed, 21 insertions, 19 deletions
diff --git a/testing/py-pypeg2/APKBUILD b/testing/py-pypeg2/APKBUILD
index 61e88e502f..54554e4a35 100644
--- a/testing/py-pypeg2/APKBUILD
+++ b/testing/py-pypeg2/APKBUILD
@@ -1,58 +1,60 @@
+# Contributor: Drew DeVault <sir@cmpwn.com>
# Contributor: Orson Teodoro <orsonteodoro@hotmail.com>
# Maintainer: Orson Teodoro <orsonteodoro@hotmail.com>
pkgname=py-pypeg2
_pkgname=pypeg2
__pkgname=pypeg
pkgver=2.15.2
-pkgrel=0
+pkgrel=2
pkgdesc="An intrinsic PEG Parser-Interpreter for Python"
url="https://fdik.org/pyPEG2/"
arch="noarch"
license="GPL-2.0-only"
_gitrev="43b84d987ec1"
-depends="py-lxml"
makedepends="py-setuptools py3-setuptools"
subpackages="py2-$_pkgname:_py2 py3-$_pkgname:_py3 $pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://bitbucket.org/fdik/$__pkgname/get/$pkgver.tar.gz"
-builddir="$srcdir"/$_pkgname-$pkgver
+builddir="$srcdir"/fdik-$__pkgname-$_gitrev
prepare() {
- mv "$srcdir"/fdik-$__pkgname-* "$builddir"
+ sed -i -e "s|PYTHON=python3.3||g" "$builddir"/Makefile
+ cp -r "$builddir" "$builddir"-py3
default_prepare
}
check() {
cd "$builddir"
python2 setup.py check
- python3 setup.py check
- sed -i -e "s|PYTHON=python3.3||g" Makefile
PYTHON="/usr/bin/python2" make test
+ cd "$builddir"-py3
+ python3 setup.py check
PYTHON="/usr/bin/python3" make test
}
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir"
+ install -d "$pkgdir"/usr/share/doc/$pkgname
+ install -t "$pkgdir"/usr/share/doc/$pkgname CHANGES.txt README.txt
+}
+
_py() {
- local python="$1"
+ local pyver="${subpkgname:2:1}"
+ local python="python$pyver"
pkgdesc="$pkgdesc (for $python)"
- depends="depends $python"
+ depends="$python ${depends//py-/py$pyver-}"
install_if="$pkgname=$pkgver-r$pkgrel $python"
- cd "$builddir"
$python setup.py install --prefix=/usr --root="$subpkgdir"
}
_py2() {
- depends="${depends//py-//py2-}"
- _py python2
+ cd "$builddir"
+ _py
}
_py3() {
- depends="${depends//py-//py3-}"
- _py python3
-}
-
-package() {
- cd "$builddir"
- install -d "$pkgdir"/usr/share/doc/$pkgname
- install -t "$pkgdir"/usr/share/doc/$pkgname CHANGES.txt README.txt
+ cd "$builddir"-py3
+ _py
}
sha512sums="425e9f56c2353687ab0a77789c209359fd0cf50a949f39fea88c2e153737fbd4e7b0c9716895606a912fa4b98ced3380361739ebddeb13f60c6aad9e41a018d7 py-pypeg2-2.15.2.tar.gz"